summaryrefslogtreecommitdiff
path: root/debian/patches/01-dont-fail-on-clean.patch
diff options
context:
space:
mode:
Diffstat (limited to 'debian/patches/01-dont-fail-on-clean.patch')
-rw-r--r--debian/patches/01-dont-fail-on-clean.patch20
1 files changed, 20 insertions, 0 deletions
diff --git a/debian/patches/01-dont-fail-on-clean.patch b/debian/patches/01-dont-fail-on-clean.patch
new file mode 100644
index 0000000..c7df96b
--- /dev/null
+++ b/debian/patches/01-dont-fail-on-clean.patch
@@ -0,0 +1,20 @@
+--- a/Makefile
++++ b/Makefile
+@@ -129,7 +129,7 @@
+ for d in ${.CURDIR}/tests ${.CURDIR}/doc; do \
+ cd $$d; \
+ ${MAKE} -m ${.CURDIR} -m ${.OBJDIR} -m ${MKFILESDIR} \
+- ${MAKEFLAGS} cleandir; \
++ ${MAKEFLAGS} cleandir || true; \
+ done
+ clean: clean_tests
+ clean_tests: configure.mk
+@@ -138,7 +138,7 @@
+ for d in ${.CURDIR}/tests ${.CURDIR}/doc; do \
+ cd $$d; \
+ ${MAKE} -m ${.CURDIR} -m ${.OBJDIR} -m ${MKFILESDIR} \
+- ${MAKEFLAGS} clean; \
++ ${MAKEFLAGS} clean || true; \
+ done
+
+ ##################################################