summaryrefslogtreecommitdiff
path: root/doc/TODO
diff options
context:
space:
mode:
Diffstat (limited to 'doc/TODO')
-rw-r--r--doc/TODO59
1 files changed, 16 insertions, 43 deletions
diff --git a/doc/TODO b/doc/TODO
index 00d77ad..f631dd9 100644
--- a/doc/TODO
+++ b/doc/TODO
@@ -1,44 +1,36 @@
============================================================
-Plan 0.26.0
+Plan 0.28.0
-- CLEANFILES: pod2htmd.tmp pod2htmi.tmp only if POD is built
+- check awk capabilities at build time
+- Hide regression tests details
+- "bmake -k regrtest/check" (mkc.minitest.mk?)
-- DISTCLEANFILES: .depend for C/C++ projects
+- strndup(SunOS-5.10, -fgetln,_compatlib)
+- PRId64
+- leveldb, strtoll, strtoull
+- wmemcpy, strnlen
+- wcsdup
+- CFLAGS0
-- MKC_FEATURES: err(err,warn etc.), fgetln(via getline(3))
- Special marker for checks that cannot be possible in cross-compiling
+- regression tests without garbage, make it look like paexec\
+
+- MKC_FEATURES: inttypes
+
Some thoughts inspired by talks with Michael Crogan
- MKASNEEDED=yes => ld --as-needed
-- VARIANTS for libraries.
-
- _mkc_done_<prj>_<trg>
- project "roundup" for testing
-- Better explain how "test" target works, maybe as a couple of slides
- in the PDF presentation. With and without mkc.minitest.mk.
-- One more example/ for TARGETS, demonstrating such things as
- "mkcmake all_clang/all_gcc" or "valgrind_test"/"gcov_test" etc.
-- Additional slides in PDF for virtual subprojects.
- Notes about "virtual subproject" in examples/.
-- Notes in examples/hello_dictd and other examples based on
- mkc.subprj.mk about what mkc.subprj.mk really does. Reference (man page)
- is not enough for newcomers. Notes about clean-SUBPRJ, all-SUBPRJ etc.
-- Better explain ../Makefile.inc included automatically. For those who
- are not familiar with *BSD it is not obvious how to use it.
- "errorcheck/configure" tests should be run in parallel. Something
like shlock(1) or flock(1) is needed for this.
-- Example is needed for how to embed autoconf-based subproject into a
- project based on mk-configure. The sad fact is autoconf/automake is
- everywhere. So, it would be nice to integrate mk-c into reality.
- mkc_imp.autotools.mk is needed for this.
- Alternative .depend generation, e.g. like it is described in GNU
make info files
-- Higher priority for fixing handling of dependencies between
- libraries and programs. In addition examples/ is needed for
+- Additional examples/ is needed for
triggering rebuild of subproject if "something" was rebuild in
another subproject (build script for example).
- Interdependencies between targetX-subprjA and targetY-subprjB (for
@@ -47,25 +39,11 @@ Some thoughts inspired by talks with Michael Crogan
<<<depend-project1:errorcheck-autotools_based_project2>>>!!!
- Steal cool features from Simon Gerraty's mk files and analyse
"meta mode" he invented.
-- Better support for working without installation to /. -rpath, additional
- directories for objects, binaries and libs.
-- symlinks in object directories to source files for easier running
- unitest, for example. lndir(1).
Some "targets" from TARGETS should set MKCHECKS to "no"
ronn(1) : markdown to man pages
- Reimplement linkme.mk. It is not flexible enough.
- - Additional type of dependencies in mkc.subprjs.mk (LIBDEPS =
- libfoo:bar ...), pass them to subprojects using enironment and
- include appropriate libfoo/linkme.mk if it is
- available. Otherwise, use default -l and -I.
- or
- - keep linkme.mk and avoid direct use of CPPFLAGS, LDADD and
- DPLIBDIRS. Instead use special variables XXX.includes,
- XXX.ldflags, XXX.ldadd, SRCDIR_<lib> and OBJDIR_<lib>.
-
custom test failed -> exit status of mkcmake should not be zero
MKC_CUSTOM_ERR.qqqq -> error message before exiting just like
@@ -79,7 +57,6 @@ ronn(1) : markdown to man pages
- BINSUBDIR, LIBSUBDIR, LIBEXECSUBDIR etc...
- Fix USE_SSP support for clang (-mllvm -stack-protector-buffer-size=1)
- - @sysconfdir@/mkc.conf
- USE_RPATH
- OBJCOPTS_<proj>
- Regression tests:
@@ -125,12 +102,8 @@ Plan 3)
run generated executables, i.e. not ready
for cross-compilation
- = symlinks to executables and libraries in ${OBJDIR}/{bin,lib}
-
= support for gettext
- = xxxDIR variable for /var
-
= mkclint?
= Command line may be limited in size.
@@ -145,7 +118,7 @@ Plan 3)
= shared libraries support for nwcc and other compilers.
= Comparison with quagmire, kBuild, CMake, scons, waf, framewerk, pmk,
- MagicMakefiles, bjam, pymake, bitmake, pkgconf,
+ MagicMakefiles, bjam, pymake, bitmake, pkgconf, Gradle
http://sourceforge.net/projects/mkbuild etc.
= Often compilers need special options to compile pthread code.