summaryrefslogtreecommitdiff
path: root/examples/hello_TARGETS/Makefile.inc
diff options
context:
space:
mode:
Diffstat (limited to 'examples/hello_TARGETS/Makefile.inc')
-rw-r--r--examples/hello_TARGETS/Makefile.inc10
1 files changed, 10 insertions, 0 deletions
diff --git a/examples/hello_TARGETS/Makefile.inc b/examples/hello_TARGETS/Makefile.inc
new file mode 100644
index 0000000..b3f20f7
--- /dev/null
+++ b/examples/hello_TARGETS/Makefile.inc
@@ -0,0 +1,10 @@
+CSCHK = test hello1 = '${.CURDIR:T}' # something useful should be here
+
+.if make(codingstylechk)
+MKCHECKS = no
+.endif
+
+.PHONY: codingstylechk
+codingstylechk:
+ @${_MESSAGE_V} "Coding style check for ${PROJECTNAME}"; \
+ ${CSCHK} || { echo FAILED 1>&2; false; }