summaryrefslogtreecommitdiff
path: root/examples/hello_TARGETS/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'examples/hello_TARGETS/Makefile')
-rw-r--r--examples/hello_TARGETS/Makefile15
1 files changed, 15 insertions, 0 deletions
diff --git a/examples/hello_TARGETS/Makefile b/examples/hello_TARGETS/Makefile
new file mode 100644
index 0000000..95fcf15
--- /dev/null
+++ b/examples/hello_TARGETS/Makefile
@@ -0,0 +1,15 @@
+SUBDIR = hello1 hello2
+
+# additional recursive target
+TARGETS += codingstylechk
+
+# We want to include man pages to the distribution tarball.
+# For this we do the following:
+# mkcmake manpages; tar -cf /tmp/tarball.tar .
+TARGETS += _manpages # _manpages is a new recursive target
+.PHONY: manpages
+manpages: _manpages
+ @rm ${MKC_CACHEDIR}/_mkc*
+
+.include "test.mk"
+.include <mkc.subdir.mk>