summaryrefslogtreecommitdiff
path: root/examples/hello_TARGETS/test.mk
diff options
context:
space:
mode:
Diffstat (limited to 'examples/hello_TARGETS/test.mk')
-rw-r--r--examples/hello_TARGETS/test.mk32
1 files changed, 32 insertions, 0 deletions
diff --git a/examples/hello_TARGETS/test.mk b/examples/hello_TARGETS/test.mk
new file mode 100644
index 0000000..6949660
--- /dev/null
+++ b/examples/hello_TARGETS/test.mk
@@ -0,0 +1,32 @@
+# I added "codingstylechk" to "test" just for mk-configure regr. test
+
+test:
+.PHONY : test_output
+test_output :
+ @:; \
+ ${OBJDIR_hello1}/hello1; \
+ ${OBJDIR_hello2}/hello2; \
+ MKCATPAGES=yes; export MKCATPAGES; \
+ \
+ echo =========== all ============; \
+ find ${.OBJDIR} -type f -o -type l | \
+ mkc_test_helper "${PREFIX}" "${.OBJDIR}"; \
+ \
+ echo ========= codingstylechk ==========; \
+ ${MAKE} ${MAKEFLAGS} cleandir 2>/dev/null 1>&2; \
+ { ${MAKE} ${MAKEFLAGS} codingstylechk 2>&1; echo cschk ex=$$?; } | \
+ env NOSORT=1 mkc_test_helper "${PREFIX}" "${.OBJDIR}"; \
+ \
+ echo ============= files ===============; \
+ find ${.OBJDIR} -type f -o -type l | \
+ mkc_test_helper "${PREFIX}" "${.OBJDIR}"; \
+ \
+ echo =========== manpages ============; \
+ env MKCATPAGES=no ${MAKE} ${MAKEFLAGS} cleandir 2>/dev/null 1>&2; \
+ ${MAKE} ${MAKEFLAGS} manpages 2>/dev/null 1>&2; \
+ find ${.OBJDIR} -type f | \
+ mkc_test_helper "${PREFIX}" "${.OBJDIR}"
+ \
+ ${MAKE} ${MAKEFLAGS} cleandir 2>/dev/null 1>&2
+
+.include <mkc.minitest.mk>