summaryrefslogtreecommitdiff
path: root/examples/hello_autoconf/test.mk
diff options
context:
space:
mode:
Diffstat (limited to 'examples/hello_autoconf/test.mk')
-rw-r--r--examples/hello_autoconf/test.mk27
1 files changed, 27 insertions, 0 deletions
diff --git a/examples/hello_autoconf/test.mk b/examples/hello_autoconf/test.mk
new file mode 100644
index 0000000..8e6586e
--- /dev/null
+++ b/examples/hello_autoconf/test.mk
@@ -0,0 +1,27 @@
+EXCL_RE='autom4te[.]cache'
+
+.PHONY : test_output
+test_output:
+ @ \
+ ${.OBJDIR}/hello_autoconf; \
+ rm -rf ${.OBJDIR}${PREFIX}; \
+ \
+ echo =========== all ============; \
+ find ${.OBJDIR} -type f | grep -Ev '${EXCL_RE}' | \
+ mkc_test_helper "${PREFIX}" "${.OBJDIR}"; \
+ \
+ echo ========== clean ===========; \
+ ${MAKE} ${MAKEFLAGS} clean > /dev/null; \
+ find ${.OBJDIR} -type f | grep -vE '${EXCL_RE}' | \
+ mkc_test_helper "${PREFIX}" "${.OBJDIR}"; \
+ \
+ echo ========== all SHRTOUT=yes ===========; \
+ ${MAKE} ${MAKEFLAGS} all SHRTOUT=yes | \
+ grep -E '^[[:alpha:]]+:'; \
+ \
+ echo ======= cleandir ==========; \
+ ${MAKE} ${MAKEFLAGS} cleandir > /dev/null; \
+ find ${.OBJDIR} -type f | grep -vE '${EXCL_RE}' | \
+ mkc_test_helper "${PREFIX}" "${.OBJDIR}"
+
+.include <mkc.minitest.mk>