summaryrefslogtreecommitdiff
path: root/examples/hello_customtests/test.mk
diff options
context:
space:
mode:
Diffstat (limited to 'examples/hello_customtests/test.mk')
-rw-r--r--examples/hello_customtests/test.mk12
1 files changed, 10 insertions, 2 deletions
diff --git a/examples/hello_customtests/test.mk b/examples/hello_customtests/test.mk
index 99e946e..adfedf7 100644
--- a/examples/hello_customtests/test.mk
+++ b/examples/hello_customtests/test.mk
@@ -1,7 +1,10 @@
+CLEANDIRS += ${.CURDIR}/testdir
+
.PHONY : test_output
test_output:
@set -e; \
rm -rf ${.OBJDIR}${PREFIX}; \
+ MKCATPAGES=yes; export MKCATPAGES; \
\
echo =========== all ============; \
find ${.OBJDIR} -type f | \
@@ -11,13 +14,13 @@ test_output:
${.OBJDIR}/hello_customtests; \
\
echo ========= install ==========; \
- ${MAKE} ${MAKEFLAGS} install DESTDIR=${.OBJDIR} \
+ ${MAKE} ${MAKEFLAGS} install -j3 DESTDIR=${.OBJDIR} \
> /dev/null; \
find ${.OBJDIR}${PREFIX} -type f -o -type d | \
mkc_test_helper "${PREFIX}" "${.OBJDIR}"; \
\
echo ======== uninstall =========; \
- ${MAKE} ${MAKEFLAGS} uninstall DESTDIR=${.OBJDIR} > /dev/null; \
+ ${MAKE} ${MAKEFLAGS} -j4 uninstall DESTDIR=${.OBJDIR} > /dev/null; \
find ${.OBJDIR}${PREFIX} -type f | \
mkc_test_helper "${PREFIX}" "${.OBJDIR}";\
\
@@ -26,6 +29,11 @@ test_output:
find ${.OBJDIR} -type f | \
mkc_test_helper "${PREFIX}" "${.OBJDIR}";\
\
+ echo ======= errorcheck + MAKEOBJDIR ===========; \
+ mkdir ${.CURDIR}/testdir || true; \
+ ${MAKE} ${MAKEFLAGS} errorcheck MAKEOBJDIR=${.CURDIR}/testdir > /dev/null; \
+ printf 'true_is_available=%s\n' `cat ${.CURDIR}/testdir/_mkc_custom_true_is_available.res`; \
+ \
echo ======= distclean ==========; \
${MAKE} ${MAKEFLAGS} distclean DESTDIR=${.OBJDIR} > /dev/null; \
find ${.OBJDIR} -type f | \