summaryrefslogtreecommitdiff
path: root/examples/hello_cxxlib/cxxlib
diff options
context:
space:
mode:
Diffstat (limited to 'examples/hello_cxxlib/cxxlib')
-rw-r--r--examples/hello_cxxlib/cxxlib/Makefile3
-rw-r--r--examples/hello_cxxlib/cxxlib/dummy.c6
-rw-r--r--examples/hello_cxxlib/cxxlib/linkme.mk6
3 files changed, 12 insertions, 3 deletions
diff --git a/examples/hello_cxxlib/cxxlib/Makefile b/examples/hello_cxxlib/cxxlib/Makefile
index a9f974a..540eb02 100644
--- a/examples/hello_cxxlib/cxxlib/Makefile
+++ b/examples/hello_cxxlib/cxxlib/Makefile
@@ -12,4 +12,7 @@ INCSSRCDIR = include
SRCS = hello_msg1.cpp hello_msg2.cpp
+MKC_SOURCE_FUNCLIBS = dummy # a part of regression test
+MKC_SOURCE_DIR.dummy.c := ${.PARSEDIR}
+
.include <mkc.lib.mk>
diff --git a/examples/hello_cxxlib/cxxlib/dummy.c b/examples/hello_cxxlib/cxxlib/dummy.c
new file mode 100644
index 0000000..a30fafb
--- /dev/null
+++ b/examples/hello_cxxlib/cxxlib/dummy.c
@@ -0,0 +1,6 @@
+/* we do use this function, this is just a part of regression test */
+void dummy_func (void);
+void dummy_func (void)
+{
+ /* we do nothing here */
+}
diff --git a/examples/hello_cxxlib/cxxlib/linkme.mk b/examples/hello_cxxlib/cxxlib/linkme.mk
index 85b9277..20864c9 100644
--- a/examples/hello_cxxlib/cxxlib/linkme.mk
+++ b/examples/hello_cxxlib/cxxlib/linkme.mk
@@ -1,5 +1,5 @@
-PATH.cxxlib := ${.PARSEDIR}
+PATH.cxxlib := ${.PARSEDIR:tA}
-CPPFLAGS += -I${PATH.cxxlib}/include
+DPINCDIRS += ${PATH.cxxlib}/include
DPLIBDIRS += ${PATH.cxxlib}
-LDADD0 += -lcxxlib
+DPLDADD += cxxlib