summaryrefslogtreecommitdiff
path: root/examples/hello_errwarn/test.mk
diff options
context:
space:
mode:
Diffstat (limited to 'examples/hello_errwarn/test.mk')
-rw-r--r--examples/hello_errwarn/test.mk19
1 files changed, 19 insertions, 0 deletions
diff --git a/examples/hello_errwarn/test.mk b/examples/hello_errwarn/test.mk
new file mode 100644
index 0000000..94f48a2
--- /dev/null
+++ b/examples/hello_errwarn/test.mk
@@ -0,0 +1,19 @@
+SUBST_CMD=sed -e 's,Not enough space,Cannot allocate memory,'
+
+.PHONY : test_output
+test_output:
+ @\
+ echo ======= ex ==========; \
+ { ${.OBJDIR}/hello err 1 2>&1 >/dev/null; echo '$$?='$$?; } | ${SUBST_CMD}; \
+ { ${.OBJDIR}/hello err 2 2>&1 >/dev/null; echo '$$?='$$?; } | ${SUBST_CMD}; \
+ { ${.OBJDIR}/hello err 3 2>&1 >/dev/null; echo '$$?='$$?; } | ${SUBST_CMD}; \
+ ${.OBJDIR}/hello errx 1 2>&1 >/dev/null; echo '$$?='$$?; \
+ ${.OBJDIR}/hello errx 2 2>&1 >/dev/null; echo '$$?='$$?; \
+ ${.OBJDIR}/hello errx 3 2>&1 >/dev/null; echo '$$?='$$?; \
+ echo ======= CLEANFILES ==========; \
+ ${MAKE} ${MAKEFLAGS} print_values VARS='CLEANFILES' MKCHECKS=no | \
+ awk '{for(i=1; i<=NF; ++i) if ($$i ~ /[.]o.?$$/) print $$i}'; \
+ echo ======= cleandir ==========; \
+ ${MAKE} ${MAKEFLAGS} cleandir > /dev/null
+
+.include <mkc.minitest.mk>