summaryrefslogtreecommitdiff
path: root/examples/hello_fgetln/test.mk
diff options
context:
space:
mode:
Diffstat (limited to 'examples/hello_fgetln/test.mk')
-rw-r--r--examples/hello_fgetln/test.mk19
1 files changed, 19 insertions, 0 deletions
diff --git a/examples/hello_fgetln/test.mk b/examples/hello_fgetln/test.mk
new file mode 100644
index 0000000..58c7925
--- /dev/null
+++ b/examples/hello_fgetln/test.mk
@@ -0,0 +1,19 @@
+FUNCS_RE=(fgetln|getline|err|progname)[.]o
+
+.PHONY : test_output
+test_output:
+ @set -e; \
+ ${.OBJDIR}/hello < ${.CURDIR}/../hello_strlcpy2/input.in; \
+ rm -rf ${.OBJDIR}${PREFIX}; \
+ \
+ echo =========== all ============; \
+ find ${.OBJDIR} -type f | grep -Ev '${FUNCS_RE}' | \
+ mkc_test_helper "${PREFIX}" "${.OBJDIR}"; \
+ \
+ echo ======= CLEANFILES ==========; \
+ ${MAKE} ${MAKEFLAGS} print_values VARS='CLEANFILES' MKCHECKS=no | \
+ awk '{for(i=1; i<=NF; ++i) if ($$i ~ /[.]o.?$$/) print $$i}'; \
+ echo ======= cleandir ==========; \
+ ${MAKE} ${MAKEFLAGS} cleandir > /dev/null
+
+.include <mkc.minitest.mk>