summaryrefslogtreecommitdiff
path: root/examples/hello_files/test.mk
diff options
context:
space:
mode:
Diffstat (limited to 'examples/hello_files/test.mk')
-rw-r--r--examples/hello_files/test.mk14
1 files changed, 7 insertions, 7 deletions
diff --git a/examples/hello_files/test.mk b/examples/hello_files/test.mk
index 72afde2..c354e53 100644
--- a/examples/hello_files/test.mk
+++ b/examples/hello_files/test.mk
@@ -1,28 +1,28 @@
.PHONY : test_output
test_output:
@set -e; \
- MKHTML=yes; export MKHTML; \
- \
+ MKCATPAGES=yes; export MKCATPAGES; \
rm -rf ${.OBJDIR}${PREFIX}; \
\
echo =========== all ============; \
+ ${MAKE} ${MAKEFLAGS} -j4 all > /dev/null; \
find ${.OBJDIR} -type f -o -type l | \
mkc_test_helper "${PREFIX}" "${.OBJDIR}"; \
\
echo ======== all+html ==========; \
- ${MAKE} ${MAKEFLAGS} all \
- > /dev/null; \
+ MKHTML=yes; export MKHTML; \
+ ${MAKE} ${MAKEFLAGS} -j4 all > /dev/null; \
find ${.OBJDIR} -type f -o -type l | \
mkc_test_helper "${PREFIX}" "${.OBJDIR}"; \
\
echo ========= install ==========; \
- ${MAKE} ${MAKEFLAGS} install DESTDIR=${.OBJDIR} \
+ ${MAKE} ${MAKEFLAGS} install -j3 DESTDIR=${.OBJDIR} \
> /dev/null; \
find ${.OBJDIR}${PREFIX} -type f -o -type l -o -type d | \
mkc_test_helper "${PREFIX}" "${.OBJDIR}"; \
\
echo ======== uninstall =========; \
- ${MAKE} ${MAKEFLAGS} uninstall DESTDIR=${.OBJDIR} > /dev/null; \
+ ${MAKE} ${MAKEFLAGS} -j4 uninstall DESTDIR=${.OBJDIR} > /dev/null; \
find ${.OBJDIR}${PREFIX} -type f -o -type l | \
mkc_test_helper "${PREFIX}" "${.OBJDIR}"; \
\
@@ -38,7 +38,7 @@ test_output:
\
echo ==== install MKINSTALL=no ====; \
MKINSTALL=no; export MKINSTALL; \
- ${MAKE} ${MAKEFLAGS} all installdirs install DESTDIR=${.OBJDIR} \
+ ${MAKE} ${MAKEFLAGS} -j4 all installdirs install -j3 DESTDIR=${.OBJDIR} \
> /dev/null; \
find ${.OBJDIR} -type f -o -type l | \
mkc_test_helper "${PREFIX}" "${.OBJDIR}"; \