summaryrefslogtreecommitdiff
path: root/examples/hello_glib2/test.mk
diff options
context:
space:
mode:
Diffstat (limited to 'examples/hello_glib2/test.mk')
-rw-r--r--examples/hello_glib2/test.mk5
1 files changed, 3 insertions, 2 deletions
diff --git a/examples/hello_glib2/test.mk b/examples/hello_glib2/test.mk
index da83e2f..8604e62 100644
--- a/examples/hello_glib2/test.mk
+++ b/examples/hello_glib2/test.mk
@@ -3,19 +3,20 @@ test_output:
@set -e; \
${.OBJDIR}/hello_glib2 | sed 's,[0-9][0-9]*,N,'; \
rm -rf ${.OBJDIR}${PREFIX}; \
+ MKCATPAGES=yes; export MKCATPAGES; \
\
echo =========== all ============; \
find ${.OBJDIR} -type f | \
mkc_test_helper "${PREFIX}" "${.OBJDIR}"; \
\
echo ========= install ==========; \
- ${MAKE} ${MAKEFLAGS} install DESTDIR=${.OBJDIR} \
+ ${MAKE} ${MAKEFLAGS} install -j3 DESTDIR=${.OBJDIR} \
> /dev/null; \
find ${.OBJDIR}${PREFIX} -type f -o -type d | \
mkc_test_helper "${PREFIX}" "${.OBJDIR}"; \
\
echo ======== uninstall =========; \
- ${MAKE} ${MAKEFLAGS} uninstall DESTDIR=${.OBJDIR} > /dev/null; \
+ ${MAKE} ${MAKEFLAGS} -j4 uninstall DESTDIR=${.OBJDIR} > /dev/null; \
find ${.OBJDIR}${PREFIX} -type f | \
mkc_test_helper "${PREFIX}" "${.OBJDIR}";\
\