summaryrefslogtreecommitdiff
path: root/examples/hello_lua3/test.mk
diff options
context:
space:
mode:
Diffstat (limited to 'examples/hello_lua3/test.mk')
-rw-r--r--examples/hello_lua3/test.mk32
1 files changed, 32 insertions, 0 deletions
diff --git a/examples/hello_lua3/test.mk b/examples/hello_lua3/test.mk
new file mode 100644
index 0000000..fdf2745
--- /dev/null
+++ b/examples/hello_lua3/test.mk
@@ -0,0 +1,32 @@
+.PHONY : test_output
+test_output:
+ @set -e; \
+ rm -rf ${.OBJDIR}/usr ${.OBJDIR}/opt; \
+ echo PROJECTNAME=${PROJECTNAME}; \
+ \
+ echo =========== all ============; \
+ find ${.OBJDIR} -type f | \
+ mkc_test_helper "${PREFIX}" "${.OBJDIR}"; \
+ \
+ echo ========= install ==========; \
+ ${MAKE} ${MAKEFLAGS} install DESTDIR=${.OBJDIR} \
+ > /dev/null; \
+ find ${.OBJDIR}/usr -type f -o -type d | \
+ mkc_test_helper "${PREFIX}" "${.OBJDIR}" | uniq; \
+ \
+ echo ======== uninstall =========; \
+ ${MAKE} ${MAKEFLAGS} uninstall DESTDIR=${.OBJDIR} > /dev/null; \
+ find ${.OBJDIR}/usr -type f | \
+ mkc_test_helper "${PREFIX}" "${.OBJDIR}"; \
+ \
+ echo ========== clean ===========; \
+ ${MAKE} ${MAKEFLAGS} clean DESTDIR=${.OBJDIR} > /dev/null; \
+ find ${.OBJDIR} -type f | \
+ mkc_test_helper "${PREFIX}" "${.OBJDIR}"; \
+ \
+ echo ======= distclean ==========; \
+ ${MAKE} ${MAKEFLAGS} distclean DESTDIR=${.OBJDIR} > /dev/null; \
+ find ${.OBJDIR} -type f | \
+ mkc_test_helper "${PREFIX}" "${.OBJDIR}"
+
+.include <mkc.minitest.mk>