summaryrefslogtreecommitdiff
path: root/examples/hello_plugins/test.mk
diff options
context:
space:
mode:
Diffstat (limited to 'examples/hello_plugins/test.mk')
-rw-r--r--examples/hello_plugins/test.mk7
1 files changed, 4 insertions, 3 deletions
diff --git a/examples/hello_plugins/test.mk b/examples/hello_plugins/test.mk
index edcf9a7..9325880 100644
--- a/examples/hello_plugins/test.mk
+++ b/examples/hello_plugins/test.mk
@@ -4,24 +4,25 @@ test_output:
rm -rf ${.OBJDIR}${PREFIX}; \
app/app plugin1/plugin1${DLL_EXT} plugin1/plugin1${DLL_EXT} | \
awk '$$3 == "address:" {$$4 = "0xF00DBEAF"} {print}'; \
+ MKCATPAGES=yes; export MKCATPAGES; \
\
echo =========== all ============; \
find ${.OBJDIR} -type f | \
mkc_test_helper "${PREFIX}" "${.OBJDIR}"; \
\
echo ========= install ==========; \
- ${MAKE} ${MAKEFLAGS} install DESTDIR=${.OBJDIR} \
+ ${MAKE} ${MAKEFLAGS} install -j3 DESTDIR=${.OBJDIR} \
> /dev/null; \
find ${.OBJDIR}${PREFIX} -type f -o -type d | \
mkc_test_helper "${PREFIX}" "${.OBJDIR}"; \
\
echo ======== uninstall =========; \
- ${MAKE} ${MAKEFLAGS} uninstall DESTDIR=${.OBJDIR} > /dev/null; \
+ ${MAKE} ${MAKEFLAGS} -j4 uninstall DESTDIR=${.OBJDIR} > /dev/null; \
find ${.OBJDIR}${PREFIX} -type f | \
mkc_test_helper "${PREFIX}" "${.OBJDIR}";\
\
echo ======== filelist ==========; \
- ${MAKE} ${MAKEFLAGS} filelist | sed 's/[.]bundle/.so/'; \
+ ${MAKE} ${MAKEFLAGS} PREFIX=/usr/local filelist | sed 's/[.]bundle/.so/'; \
\
echo ========== clean ===========; \
${MAKE} ${MAKEFLAGS} clean DESTDIR=${.OBJDIR} > /dev/null; \