summaryrefslogtreecommitdiff
path: root/examples/hello_progs/test.mk
diff options
context:
space:
mode:
Diffstat (limited to 'examples/hello_progs/test.mk')
-rw-r--r--examples/hello_progs/test.mk10
1 files changed, 8 insertions, 2 deletions
diff --git a/examples/hello_progs/test.mk b/examples/hello_progs/test.mk
index bd90e8b..a0741ca 100644
--- a/examples/hello_progs/test.mk
+++ b/examples/hello_progs/test.mk
@@ -5,19 +5,20 @@ test_output:
${.OBJDIR}/client; \
${.OBJDIR}/server; \
rm -rf ${.OBJDIR}${PREFIX}; \
+ MKCATPAGES=yes; export MKCATPAGES; \
\
echo =========== all ============; \
find ${.OBJDIR} -type f | \
mkc_test_helper "${PREFIX}" "${.OBJDIR}"; \
\
echo ========= install ==========; \
- ${MAKE} ${MAKEFLAGS} install DESTDIR=${.OBJDIR} \
+ ${MAKE} ${MAKEFLAGS} install -j3 DESTDIR=${.OBJDIR} \
> /dev/null; \
find ${.OBJDIR}${PREFIX} -type f -o -type d | \
mkc_test_helper "${PREFIX}" "${.OBJDIR}"; \
\
echo ======== uninstall =========; \
- ${MAKE} ${MAKEFLAGS} uninstall DESTDIR=${.OBJDIR} > /dev/null; \
+ ${MAKE} ${MAKEFLAGS} -j4 uninstall DESTDIR=${.OBJDIR} > /dev/null; \
find ${.OBJDIR}${PREFIX} -type f | \
mkc_test_helper "${PREFIX}" "${.OBJDIR}";\
\
@@ -26,6 +27,11 @@ test_output:
find ${.OBJDIR} -type f | \
mkc_test_helper "${PREFIX}" "${.OBJDIR}";\
\
+ echo ========== depend ===========; \
+ ${MAKE} ${MAKEFLAGS} depend > /dev/null; \
+ find ${.OBJDIR} -type f | \
+ mkc_test_helper "${PREFIX}" "${.OBJDIR}";\
+ \
echo ========== server ===========; \
${MAKE} ${MAKEFLAGS} server > /dev/null; \
find ${.OBJDIR} -type f | \