summaryrefslogtreecommitdiff
path: root/examples/hello_scripts/test.mk
diff options
context:
space:
mode:
Diffstat (limited to 'examples/hello_scripts/test.mk')
-rw-r--r--examples/hello_scripts/test.mk7
1 files changed, 4 insertions, 3 deletions
diff --git a/examples/hello_scripts/test.mk b/examples/hello_scripts/test.mk
index f33a6a7..5449f8a 100644
--- a/examples/hello_scripts/test.mk
+++ b/examples/hello_scripts/test.mk
@@ -5,6 +5,7 @@ test_output:
${.CURDIR}/hello_world2; \
${.CURDIR}/hello_world3; \
\
+ MKCATPAGES=yes; export MKCATPAGES; \
rm -rf ${.OBJDIR}${PREFIX}; \
\
echo =========== all ============; \
@@ -12,13 +13,13 @@ test_output:
mkc_test_helper "${PREFIX}" "${.OBJDIR}"; \
\
echo ========= install ==========; \
- ${MAKE} ${MAKEFLAGS} install DESTDIR=${.OBJDIR} \
+ ${MAKE} ${MAKEFLAGS} install -j3 DESTDIR=${.OBJDIR} \
> /dev/null; \
find ${.OBJDIR}${PREFIX} -type f -o -type d | \
mkc_test_helper "${PREFIX}" "${.OBJDIR}"; \
\
echo ======== uninstall =========; \
- ${MAKE} ${MAKEFLAGS} uninstall DESTDIR=${.OBJDIR} > /dev/null; \
+ ${MAKE} ${MAKEFLAGS} -j4 uninstall DESTDIR=${.OBJDIR} > /dev/null; \
find ${.OBJDIR}${PREFIX} -type f | \
mkc_test_helper "${PREFIX}" "${.OBJDIR}"; \
\
@@ -34,7 +35,7 @@ test_output:
\
echo ==== install MKINSTALL=no ====; \
MKINSTALL=no; export MKINSTALL; \
- ${MAKE} ${MAKEFLAGS} all installdirs install DESTDIR=${.OBJDIR} \
+ ${MAKE} ${MAKEFLAGS} -j4 all installdirs install -j3 DESTDIR=${.OBJDIR} \
> /dev/null; \
find ${.OBJDIR} -type f -o -type l | \
mkc_test_helper "${PREFIX}" "${.OBJDIR}"; \