summaryrefslogtreecommitdiff
path: root/examples/hello_sizeof/test.mk
diff options
context:
space:
mode:
Diffstat (limited to 'examples/hello_sizeof/test.mk')
-rw-r--r--examples/hello_sizeof/test.mk5
1 files changed, 3 insertions, 2 deletions
diff --git a/examples/hello_sizeof/test.mk b/examples/hello_sizeof/test.mk
index 174eb9d..1f6b6e2 100644
--- a/examples/hello_sizeof/test.mk
+++ b/examples/hello_sizeof/test.mk
@@ -3,19 +3,20 @@ test_output:
@set -e; \
${.OBJDIR}/sizeof_test | tr '1248' 'nnnn'; \
rm -rf ${.OBJDIR}${PREFIX}; \
+ MKCATPAGES=yes; export MKCATPAGES; \
\
echo =========== all ============; \
find ${.OBJDIR} -type f | \
mkc_test_helper "${PREFIX}" "${.OBJDIR}"; \
\
echo ========= install ==========; \
- ${MAKE} ${MAKEFLAGS} install DESTDIR=${.OBJDIR} \
+ ${MAKE} ${MAKEFLAGS} install -j3 DESTDIR=${.OBJDIR} \
> /dev/null; \
find ${.OBJDIR}${PREFIX} -type f -o -type d | \
mkc_test_helper "${PREFIX}" "${.OBJDIR}"; \
\
echo ======== uninstall =========; \
- ${MAKE} ${MAKEFLAGS} uninstall DESTDIR=${.OBJDIR} > /dev/null; \
+ ${MAKE} ${MAKEFLAGS} -j4 uninstall DESTDIR=${.OBJDIR} > /dev/null; \
find ${.OBJDIR}${PREFIX} -type f | \
mkc_test_helper "${PREFIX}" "${.OBJDIR}";\
\