summaryrefslogtreecommitdiff
path: root/examples/hello_strlcpy/test.mk
diff options
context:
space:
mode:
Diffstat (limited to 'examples/hello_strlcpy/test.mk')
-rw-r--r--examples/hello_strlcpy/test.mk33
1 files changed, 33 insertions, 0 deletions
diff --git a/examples/hello_strlcpy/test.mk b/examples/hello_strlcpy/test.mk
new file mode 100644
index 0000000..ffa417d
--- /dev/null
+++ b/examples/hello_strlcpy/test.mk
@@ -0,0 +1,33 @@
+.PHONY : test_output
+test_output:
+ @set -e; \
+ ${.OBJDIR}/hello4 < ${.CURDIR}/input.in; \
+ rm -rf ${.OBJDIR}${PREFIX}; \
+ \
+ echo =========== all ============; \
+ find ${.OBJDIR} -type f | grep -v 'strlcpy[.]o' | \
+ mkc_test_helper "${PREFIX}" "${.OBJDIR}"; \
+ \
+ echo ========= install ==========; \
+ ${MAKE} ${MAKEFLAGS} install DESTDIR=${.OBJDIR} \
+ > /dev/null; \
+ find ${.OBJDIR}${PREFIX} -type f -o -type d | \
+ grep -v 'strlcpy[.]o' | \
+ mkc_test_helper "${PREFIX}" "${.OBJDIR}"; \
+ \
+ echo ======== uninstall =========; \
+ ${MAKE} ${MAKEFLAGS} uninstall DESTDIR=${.OBJDIR} > /dev/null; \
+ find ${.OBJDIR}${PREFIX} -type f | grep -v 'strlcpy[.]o' | \
+ mkc_test_helper "${PREFIX}" "${.OBJDIR}"; \
+ \
+ echo ========== clean ===========; \
+ ${MAKE} ${MAKEFLAGS} clean DESTDIR=${.OBJDIR} > /dev/null; \
+ find ${.OBJDIR} -type f | grep -v 'strlcpy[.]o' | \
+ mkc_test_helper "${PREFIX}" "${.OBJDIR}"; \
+ \
+ echo ======= distclean ==========; \
+ ${MAKE} ${MAKEFLAGS} distclean DESTDIR=${.OBJDIR} > /dev/null; \
+ find ${.OBJDIR} -type f | grep -v 'strlcpy[.]o' | \
+ mkc_test_helper "${PREFIX}" "${.OBJDIR}"
+
+.include <mkc.minitest.mk>