summaryrefslogtreecommitdiff
path: root/examples/hello_strlcpy/test.mk
diff options
context:
space:
mode:
Diffstat (limited to 'examples/hello_strlcpy/test.mk')
-rw-r--r--examples/hello_strlcpy/test.mk27
1 files changed, 16 insertions, 11 deletions
diff --git a/examples/hello_strlcpy/test.mk b/examples/hello_strlcpy/test.mk
index ffa417d..e0155bb 100644
--- a/examples/hello_strlcpy/test.mk
+++ b/examples/hello_strlcpy/test.mk
@@ -1,33 +1,38 @@
.PHONY : test_output
test_output:
@set -e; \
- ${.OBJDIR}/hello4 < ${.CURDIR}/input.in; \
+ ${.OBJDIR}/hello < ${.CURDIR}/input.in; \
rm -rf ${.OBJDIR}${PREFIX}; \
+ MKCATPAGES=yes; export MKCATPAGES; \
\
echo =========== all ============; \
- find ${.OBJDIR} -type f | grep -v 'strlcpy[.]o' | \
+ find ${.OBJDIR} -type f | grep -Ev '(strlcpy|getline)[.]o' | \
mkc_test_helper "${PREFIX}" "${.OBJDIR}"; \
\
echo ========= install ==========; \
- ${MAKE} ${MAKEFLAGS} install DESTDIR=${.OBJDIR} \
+ ${MAKE} ${MAKEFLAGS} install -j3 DESTDIR=${.OBJDIR} \
> /dev/null; \
find ${.OBJDIR}${PREFIX} -type f -o -type d | \
- grep -v 'strlcpy[.]o' | \
+ grep -vE '(strlcpy|getline)[.]o' | \
mkc_test_helper "${PREFIX}" "${.OBJDIR}"; \
\
echo ======== uninstall =========; \
- ${MAKE} ${MAKEFLAGS} uninstall DESTDIR=${.OBJDIR} > /dev/null; \
- find ${.OBJDIR}${PREFIX} -type f | grep -v 'strlcpy[.]o' | \
+ ${MAKE} ${MAKEFLAGS} -j4 uninstall DESTDIR=${.OBJDIR} > /dev/null; \
+ find ${.OBJDIR}${PREFIX} -type f | grep -vE '(strlcpy|getline)[.]o' | \
mkc_test_helper "${PREFIX}" "${.OBJDIR}"; \
\
echo ========== clean ===========; \
- ${MAKE} ${MAKEFLAGS} clean DESTDIR=${.OBJDIR} > /dev/null; \
- find ${.OBJDIR} -type f | grep -v 'strlcpy[.]o' | \
+ ${MAKE} ${MAKEFLAGS} clean > /dev/null; \
+ find ${.OBJDIR} -type f | grep -vE '(strlcpy|getline)[.]o' | \
mkc_test_helper "${PREFIX}" "${.OBJDIR}"; \
\
echo ======= distclean ==========; \
- ${MAKE} ${MAKEFLAGS} distclean DESTDIR=${.OBJDIR} > /dev/null; \
- find ${.OBJDIR} -type f | grep -v 'strlcpy[.]o' | \
- mkc_test_helper "${PREFIX}" "${.OBJDIR}"
+ ${MAKE} ${MAKEFLAGS} distclean > /dev/null; \
+ find ${.OBJDIR} -type f | grep -vE '(strlcpy|getline)[.]o' | \
+ mkc_test_helper "${PREFIX}" "${.OBJDIR}"; \
+ \
+ echo ======= CLEANFILES ==========; \
+ ${MAKE} ${MAKEFLAGS} print-values VARS='CLEANFILES' MKCHECKS=no | \
+ awk '{for(i=1; i<=NF; ++i) if ($$i ~ /[.]o$$/) print $$i}'
.include <mkc.minitest.mk>