summaryrefslogtreecommitdiff
path: root/examples/hello_subdirs/prog1/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'examples/hello_subdirs/prog1/Makefile')
-rw-r--r--examples/hello_subdirs/prog1/Makefile6
1 files changed, 5 insertions, 1 deletions
diff --git a/examples/hello_subdirs/prog1/Makefile b/examples/hello_subdirs/prog1/Makefile
index d103cbe..0a4c0ad 100644
--- a/examples/hello_subdirs/prog1/Makefile
+++ b/examples/hello_subdirs/prog1/Makefile
@@ -1,8 +1,12 @@
PROG = prog1
-SCRIPTS = prog1.sh prog1.awk
+SCRIPTS = prog1.sh ${INSCRIPTS}
+INSCRIPTS = prog1.awk
WARNS = 4
+MKC_REQUIRE_PROGS = awk
+INTEXTS_REPLS = AWK ${PROG.awk}
+
# Do not set SCRIPTSNAME in project's Makefile!
# This is just a regression test.
SCRIPTSNAME_prog1.awk = program1.awk