summaryrefslogtreecommitdiff
path: root/examples/hello_superfs/Makefile.inc
diff options
context:
space:
mode:
Diffstat (limited to 'examples/hello_superfs/Makefile.inc')
-rw-r--r--examples/hello_superfs/Makefile.inc15
1 files changed, 14 insertions, 1 deletions
diff --git a/examples/hello_superfs/Makefile.inc b/examples/hello_superfs/Makefile.inc
index d29359b..57c8208 100644
--- a/examples/hello_superfs/Makefile.inc
+++ b/examples/hello_superfs/Makefile.inc
@@ -1 +1,14 @@
-BINDIR?= ${SBINDIR}
+BINDIR ?= ${SBINDIR}
+
+.ifdef MICHAEL_MODE
+# If MICHAEL_MODE environment variabe is set, everything
+# is installed to temporary directory after build and
+# uninstalled before cleaning.
+# This feature may be useful for development
+# and was proposed by Michael Crogan.
+PREFIX = ${TMPPREFIX}
+INSTALL = mkc_install
+COPY = -l # symlinks instead of copying/moving
+post_all: install
+pre_clean: uninstall
+.endif