summaryrefslogtreecommitdiff
path: root/examples/hello_superfs
diff options
context:
space:
mode:
Diffstat (limited to 'examples/hello_superfs')
-rw-r--r--examples/hello_superfs/Makefile4
-rw-r--r--examples/hello_superfs/expect.out26
-rw-r--r--examples/hello_superfs/test.mk13
3 files changed, 34 insertions, 9 deletions
diff --git a/examples/hello_superfs/Makefile b/examples/hello_superfs/Makefile
index c58ab37..81442e4 100644
--- a/examples/hello_superfs/Makefile
+++ b/examples/hello_superfs/Makefile
@@ -1,6 +1,4 @@
-SUBPRJ = mkfs_superfs fsck_superfs \
- docs \
- mkfs_superfs:tools fsck_superfs:tools
+SUBPRJ = docs mkfs_superfs:tools fsck_superfs:tools
SUBPRJ_DFLT = mkfs_superfs fsck_superfs docs
diff --git a/examples/hello_superfs/expect.out b/examples/hello_superfs/expect.out
index 542cf1c..45af717 100644
--- a/examples/hello_superfs/expect.out
+++ b/examples/hello_superfs/expect.out
@@ -14,14 +14,12 @@
/objdir/fsck_superfs/fsck_superfs
/objdir/fsck_superfs/fsck_superfs.8
/objdir/fsck_superfs/fsck_superfs.c
-/objdir/fsck_superfs/fsck_superfs.cat8
/objdir/fsck_superfs/fsck_superfs.o
/objdir/hello_superfs.test.out.tmp
/objdir/mkfs_superfs/Makefile
/objdir/mkfs_superfs/mkfs_superfs
/objdir/mkfs_superfs/mkfs_superfs.8
/objdir/mkfs_superfs/mkfs_superfs.c
-/objdir/mkfs_superfs/mkfs_superfs.cat8
/objdir/mkfs_superfs/mkfs_superfs.o
/objdir/test.mk
========= install ==========
@@ -63,6 +61,30 @@
/objdir/mkfs_superfs/mkfs_superfs.8
/objdir/mkfs_superfs/mkfs_superfs.c
/objdir/test.mk
+========== depend ===========
+/objdir/Makefile
+/objdir/Makefile.inc
+/objdir/_mkc_compiler_type.err
+/objdir/_mkc_compiler_type.res
+/objdir/_mkc_prog_cc.err
+/objdir/_mkc_prog_cc.res
+/objdir/docs/LICENSE
+/objdir/docs/Makefile
+/objdir/docs/NEWS
+/objdir/docs/README
+/objdir/expect.out
+/objdir/fsck_superfs/.depend
+/objdir/fsck_superfs/Makefile
+/objdir/fsck_superfs/fsck_superfs.8
+/objdir/fsck_superfs/fsck_superfs.c
+/objdir/fsck_superfs/fsck_superfs.d
+/objdir/hello_superfs.test.out.tmp
+/objdir/mkfs_superfs/.depend
+/objdir/mkfs_superfs/Makefile
+/objdir/mkfs_superfs/mkfs_superfs.8
+/objdir/mkfs_superfs/mkfs_superfs.c
+/objdir/mkfs_superfs/mkfs_superfs.d
+/objdir/test.mk
======= distclean ==========
/objdir/Makefile
/objdir/Makefile.inc
diff --git a/examples/hello_superfs/test.mk b/examples/hello_superfs/test.mk
index 6ce8018..90f220d 100644
--- a/examples/hello_superfs/test.mk
+++ b/examples/hello_superfs/test.mk
@@ -1,21 +1,21 @@
.PHONY : test_output
test_output:
@set -e; \
- \
rm -rf ${.OBJDIR}${PREFIX}; \
+ MKCATPAGES=yes; export MKCATPAGES; \
\
echo =========== all ============; \
find ${.OBJDIR} -type f -o -type l | \
mkc_test_helper "${PREFIX}" "${.OBJDIR}"; \
\
echo ========= install ==========; \
- ${MAKE} ${MAKEFLAGS} install DESTDIR=${.OBJDIR} \
+ ${MAKE} ${MAKEFLAGS} install -j3 DESTDIR=${.OBJDIR} \
> /dev/null; \
find ${.OBJDIR}${PREFIX} -type f -o -type l -o -type d | \
mkc_test_helper "${PREFIX}" "${.OBJDIR}"; \
\
echo ======== uninstall =========; \
- ${MAKE} ${MAKEFLAGS} uninstall DESTDIR=${.OBJDIR} > /dev/null; \
+ ${MAKE} ${MAKEFLAGS} -j4 uninstall DESTDIR=${.OBJDIR} > /dev/null; \
find ${.OBJDIR}${PREFIX} -type f -o -type l | \
mkc_test_helper "${PREFIX}" "${.OBJDIR}"; \
\
@@ -24,6 +24,11 @@ test_output:
find ${.OBJDIR} -type f -o -type l | \
mkc_test_helper "${PREFIX}" "${.OBJDIR}"; \
\
+ echo ========== depend ===========; \
+ ${MAKE} ${MAKEFLAGS} depend DESTDIR=${.OBJDIR} > /dev/null; \
+ find ${.OBJDIR} -type f -o -type l | \
+ mkc_test_helper "${PREFIX}" "${.OBJDIR}"; \
+ \
echo ======= distclean ==========; \
${MAKE} ${MAKEFLAGS} distclean DESTDIR=${.OBJDIR} > /dev/null; \
find ${.OBJDIR} -type f -o -type l | \
@@ -37,7 +42,7 @@ test_output:
\
echo ==== install MKINSTALL=no ====; \
MKINSTALL=no; export MKINSTALL; \
- ${MAKE} ${MAKEFLAGS} all installdirs install DESTDIR=${.OBJDIR} \
+ ${MAKE} ${MAKEFLAGS} all installdirs install -j3 DESTDIR=${.OBJDIR} \
> /dev/null; \
find ${.OBJDIR} -type f -o -type l | \
mkc_test_helper "${PREFIX}" "${.OBJDIR}"; \