summaryrefslogtreecommitdiff
path: root/examples/hello_world/test.mk
diff options
context:
space:
mode:
Diffstat (limited to 'examples/hello_world/test.mk')
-rw-r--r--examples/hello_world/test.mk22
1 files changed, 13 insertions, 9 deletions
diff --git a/examples/hello_world/test.mk b/examples/hello_world/test.mk
index adc16fd..6676191 100644
--- a/examples/hello_world/test.mk
+++ b/examples/hello_world/test.mk
@@ -5,6 +5,7 @@ tartf_cleanup= sed -e 's,^[.]/,,' -e 's,/$$,,' -e '/^[.]*$$/ d'
.PHONY : test_output
test_output:
@set -e; LC_ALL=C; export LC_ALL; \
+ MKCATPAGES=yes; export MKCATPAGES; \
echo PROJECTNAME=${PROJECTNAME}; \
${.OBJDIR}/hello_world; \
rm -rf ${.OBJDIR}${PREFIX}; \
@@ -14,13 +15,13 @@ test_output:
mkc_test_helper "${PREFIX}" "${.OBJDIR}"; \
\
echo ========= install ==========; \
- ${MAKE} ${MAKEFLAGS} install DESTDIR=${.OBJDIR} \
+ ${MAKE} ${MAKEFLAGS} install -j3 DESTDIR=${.OBJDIR} \
> /dev/null; \
find ${.OBJDIR}${PREFIX} -type f -o -type d | \
mkc_test_helper "${PREFIX}" "${.OBJDIR}"; \
\
echo ======== uninstall =========; \
- ${MAKE} ${MAKEFLAGS} uninstall DESTDIR=${.OBJDIR} > /dev/null; \
+ ${MAKE} ${MAKEFLAGS} -j4 uninstall DESTDIR=${.OBJDIR} > /dev/null; \
find ${.OBJDIR}${PREFIX} -type f | \
mkc_test_helper "${PREFIX}" "${.OBJDIR}";\
\
@@ -30,21 +31,24 @@ test_output:
mkc_test_helper "${PREFIX}" "${.OBJDIR}";\
\
echo ======== bin_tar ===========; \
- ${MAKE} ${MAKEFLAGS} bin_tar > /dev/null; \
- ${TAR} -tf ${.CURDIR:T}.tar | sort | ${tartf_cleanup}; \
+ ${MAKE} ${MAKEFLAGS} PREFIX=/usr/local bin_tar > /dev/null; \
+ ${TAR} -tf ${.CURDIR:T}.tar | \
+ sort | ${tartf_cleanup}; \
\
echo ======== bin_targz ===========; \
- ${MAKE} ${MAKEFLAGS} bin_targz > /dev/null; \
+ ${MAKE} ${MAKEFLAGS} PREFIX=/usr/local bin_targz > /dev/null; \
${GZIP} -dc ${.CURDIR:T}.tar.gz | \
- ${TAR} -tf - | sort | ${tartf_cleanup}; \
+ ${TAR} -tf - | \
+ sort | ${tartf_cleanup}; \
\
echo ======== bin_tarbz2 ===========; \
- ${MAKE} ${MAKEFLAGS} bin_tarbz2 > /dev/null; \
+ ${MAKE} ${MAKEFLAGS} PREFIX=/usr/local bin_tarbz2 > /dev/null; \
${BZIP2} -dc ${.CURDIR:T}.tar.bz2 | \
- ${TAR} -tf - | sort | ${tartf_cleanup}; \
+ ${TAR} -tf - | \
+ sort | ${tartf_cleanup}; \
\
echo ======= filelist ===========; \
- ${MAKE} ${MAKEFLAGS} filelist; \
+ ${MAKE} ${MAKEFLAGS} PREFIX=/usr/local filelist; \
\
echo ======= distclean ==========; \
${MAKE} ${MAKEFLAGS} distclean DESTDIR=${.OBJDIR} > /dev/null; \