summaryrefslogtreecommitdiff
path: root/examples/hello_yacc/test.mk
diff options
context:
space:
mode:
Diffstat (limited to 'examples/hello_yacc/test.mk')
-rw-r--r--examples/hello_yacc/test.mk15
1 files changed, 11 insertions, 4 deletions
diff --git a/examples/hello_yacc/test.mk b/examples/hello_yacc/test.mk
index 7617a5f..71840f8 100644
--- a/examples/hello_yacc/test.mk
+++ b/examples/hello_yacc/test.mk
@@ -1,6 +1,8 @@
.PHONY : test_output
test_output:
@set -e; \
+ MKCATPAGES=yes; export MKCATPAGES; \
+ \
${.OBJDIR}/hello_calc < ${.CURDIR}/input.txt; \
rm -rf ${.OBJDIR}${PREFIX}; \
\
@@ -9,18 +11,23 @@ test_output:
mkc_test_helper "${PREFIX}" "${.OBJDIR}"; \
\
echo ========= install ==========; \
- ${MAKE} ${MAKEFLAGS} install DESTDIR=${.OBJDIR} \
+ ${MAKE} ${MAKEFLAGS} install -j3 DESTDIR=${.OBJDIR} \
> /dev/null; \
find ${.OBJDIR}${PREFIX} -type f -o -type d | \
mkc_test_helper "${PREFIX}" "${.OBJDIR}"; \
\
echo ======== uninstall =========; \
- ${MAKE} ${MAKEFLAGS} uninstall DESTDIR=${.OBJDIR} > /dev/null; \
+ ${MAKE} ${MAKEFLAGS} -j4 uninstall DESTDIR=${.OBJDIR} > /dev/null; \
find ${.OBJDIR}${PREFIX} -type f | \
mkc_test_helper "${PREFIX}" "${.OBJDIR}";\
\
echo ========== clean ===========; \
- ${MAKE} ${MAKEFLAGS} clean DESTDIR=${.OBJDIR} > /dev/null; \
+ ${MAKE} ${MAKEFLAGS} clean > /dev/null; \
+ find ${.OBJDIR} -type f | \
+ mkc_test_helper "${PREFIX}" "${.OBJDIR}";\
+ \
+ echo ========== depend ===========; \
+ ${MAKE} ${MAKEFLAGS} depend > /dev/null; \
find ${.OBJDIR} -type f | \
mkc_test_helper "${PREFIX}" "${.OBJDIR}";\
\
@@ -30,7 +37,7 @@ test_output:
all 2>/dev/null | mkc_test_helper2; \
\
echo ======= distclean ==========; \
- ${MAKE} ${MAKEFLAGS} distclean DESTDIR=${.OBJDIR} > /dev/null; \
+ ${MAKE} ${MAKEFLAGS} distclean > /dev/null; \
find ${.OBJDIR} -type f | \
mkc_test_helper "${PREFIX}" "${.OBJDIR}"