summaryrefslogtreecommitdiff
path: root/examples/subprojects/libhello2/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'examples/subprojects/libhello2/Makefile')
-rw-r--r--examples/subprojects/libhello2/Makefile14
1 files changed, 14 insertions, 0 deletions
diff --git a/examples/subprojects/libhello2/Makefile b/examples/subprojects/libhello2/Makefile
new file mode 100644
index 0000000..8b93678
--- /dev/null
+++ b/examples/subprojects/libhello2/Makefile
@@ -0,0 +1,14 @@
+LIB = hello2
+SRCS = hello2.c
+MAN = hello2.3
+
+INCS != echo include/*.h
+
+MKINSTALL ?= no # This is internal library, do not install it.
+
+CPPFLAGS += -I${.CURDIR}/include
+CFLAGS += -DHELLO_VERSION='"${VERSION}"'
+
+.include "../version.mk"
+
+.include <mkc.lib.mk>