summaryrefslogtreecommitdiff
path: root/examples/subprojects/test.mk
diff options
context:
space:
mode:
Diffstat (limited to 'examples/subprojects/test.mk')
-rw-r--r--examples/subprojects/test.mk4
1 files changed, 3 insertions, 1 deletions
diff --git a/examples/subprojects/test.mk b/examples/subprojects/test.mk
index 46ac375..27b2071 100644
--- a/examples/subprojects/test.mk
+++ b/examples/subprojects/test.mk
@@ -9,8 +9,9 @@ test_output :
rm -rf ${.OBJDIR}${PREFIX}; \
LD_LIBRARY_PATH=${.CURDIR}/libhello1:${.CURDIR}/libhello2:$$LD_LIBRARY_PATH; \
DYLD_LIBRARY_PATH=${.CURDIR}/libhello1:${.CURDIR}/libhello2:$$LD_LIBRARY_PATH; \
+ LIBRARY_PATH=$$LIBRARY_PATH:$$LD_LIBRARY_PATH; \
MKINSTALLDIRS=no; \
- export LD_LIBRARY_PATH DYLD_LIBRARY_PATH; \
+ export LD_LIBRARY_PATH DYLD_LIBRARY_PATH LIBRARY_PATH; \
${.CURDIR}/hello/hello_subprojects; \
${.CURDIR}/hello/hello_subprojects2; \
\
@@ -21,6 +22,7 @@ test_output :
echo ===== all SHRTOUT=yes ======; \
${MAKE} ${MAKEFLAGS} clean > /dev/null; \
${MAKE} ${MAKEFLAGS} all SHRTOUT=YES 2>&1 | \
+ grep -v warning: | \
mkc_test_helper_paths; \
\
echo ========= installdirs ==========; \