summaryrefslogtreecommitdiff
path: root/examples/subprojects/test.mk
diff options
context:
space:
mode:
Diffstat (limited to 'examples/subprojects/test.mk')
-rw-r--r--examples/subprojects/test.mk16
1 files changed, 9 insertions, 7 deletions
diff --git a/examples/subprojects/test.mk b/examples/subprojects/test.mk
index 1869272..d3b88cc 100644
--- a/examples/subprojects/test.mk
+++ b/examples/subprojects/test.mk
@@ -1,6 +1,8 @@
.PHONY : test_output
test_output :
@set -e; \
+ MKCATPAGES=yes; export MKCATPAGES; \
+ \
echo PROJECTNAME=${PROJECTNAME}; \
rm -rf ${.OBJDIR}${PREFIX}; \
LD_LIBRARY_PATH=${.CURDIR}/libhello1:${.CURDIR}/libhello2:$$LD_LIBRARY_PATH; \
@@ -27,13 +29,13 @@ test_output :
mkc_test_helper "${PREFIX}" "${.OBJDIR}"; \
\
echo ========= install ==========; \
- ${MAKE} ${MAKEFLAGS} install DESTDIR=${.OBJDIR} \
+ ${MAKE} ${MAKEFLAGS} install -j3 DESTDIR=${.OBJDIR} \
> /dev/null; \
find ${.OBJDIR}${PREFIX} -type f -o -type l -o -type d | \
mkc_test_helper "${PREFIX}" "${.OBJDIR}"; \
\
echo ======== uninstall =========; \
- ${MAKE} ${MAKEFLAGS} uninstall DESTDIR=${.OBJDIR} > /dev/null; \
+ ${MAKE} ${MAKEFLAGS} -j4 uninstall DESTDIR=${.OBJDIR} > /dev/null; \
find ${.OBJDIR}${PREFIX} -type f -o -type l | \
mkc_test_helper "${PREFIX}" "${.OBJDIR}";\
\
@@ -55,24 +57,24 @@ test_output :
\
echo ========= libhello1 ==========; \
${MAKE} ${MAKEFLAGS} libhello1 DESTDIR=${.OBJDIR} > /dev/null; \
- find ${.OBJDIR} -type f -o -type l -o -type d | \
+ find ${.OBJDIR} -type f -o -type l | \
mkc_test_helper "${PREFIX}" "${.OBJDIR}"; \
\
echo ========= all-libhello2 ==========; \
- ${MAKE} ${MAKEFLAGS} all-libhello2 DESTDIR=${.OBJDIR} > /dev/null; \
- find ${.OBJDIR} -type f -o -type l -o -type d | \
+ ${MAKE} ${MAKEFLAGS} -j4 all-libhello2 DESTDIR=${.OBJDIR} > /dev/null; \
+ find ${.OBJDIR} -type f -o -type l | \
mkc_test_helper "${PREFIX}" "${.OBJDIR}"; \
\
echo ========= cleandir-libhello1 ==========; \
${MAKE} ${MAKEFLAGS} cleandir-libhello1 DESTDIR=${.OBJDIR} > /dev/null; \
- find ${.OBJDIR} -type f -o -type l -o -type d | \
+ find ${.OBJDIR} -type f -o -type l | \
mkc_test_helper "${PREFIX}" "${.OBJDIR}"; \
\
${MAKE} ${MAKEFLAGS} distclean DESTDIR=${.OBJDIR} > /dev/null; \
\
echo ======= library dependencies =======; \
PREFIX=${.CURDIR}/usr; export PREFIX; \
- ${MAKE} ${MAKEFLAGS} all installdirs install >&2; \
+ ${MAKE} ${MAKEFLAGS} all installdirs install -j3 >&2; \
LD_LIBRARY_PATH=${.CURDIR}/usr/lib; \
DYLD_LIBRARY_PATH=${.CURDIR}/usr/lib; \
export LD_LIBRARY_PATH DYLD_LIBRARY_PATH; \