summaryrefslogtreecommitdiff
path: root/examples/subprojects
diff options
context:
space:
mode:
Diffstat (limited to 'examples/subprojects')
-rw-r--r--examples/subprojects/expect.out17
-rw-r--r--examples/subprojects/hello/hello_subprojects.1.in1
-rw-r--r--examples/subprojects/test.mk16
3 files changed, 9 insertions, 25 deletions
diff --git a/examples/subprojects/expect.out b/examples/subprojects/expect.out
index 9331b5c..d26c974 100644
--- a/examples/subprojects/expect.out
+++ b/examples/subprojects/expect.out
@@ -19,7 +19,6 @@ My email is vle@gmx.net
/objdir/hello/hello_subprojects.1
/objdir/hello/hello_subprojects.1.in
/objdir/hello/hello_subprojects.c
-/objdir/hello/hello_subprojects.cat1
/objdir/hello/hello_subprojects.o
/objdir/hello/hello_subprojects2
/objdir/hello/hello_subprojects2.in
@@ -37,7 +36,6 @@ My email is vle@gmx.net
/objdir/libhello2/Makefile
/objdir/libhello2/hello2.3
/objdir/libhello2/hello2.c
-/objdir/libhello2/hello2.cat3
/objdir/libhello2/hello2.o
/objdir/libhello2/include/hello2.h
/objdir/libhello2/libhello2.a
@@ -165,20 +163,17 @@ GEN: hello_subprojects2
/objdir/test.mk
/objdir/version.mk
========= libhello1 ==========
-/objdir
/objdir/Makefile
/objdir/_mkc_compiler_type.err
/objdir/_mkc_compiler_type.res
/objdir/_mkc_prog_cc.err
/objdir/_mkc_prog_cc.res
/objdir/expect.out
-/objdir/hello
/objdir/hello/Makefile
/objdir/hello/hello_subprojects.1.in
/objdir/hello/hello_subprojects.c
/objdir/hello/hello_subprojects2.in
/objdir/hello/test.mk
-/objdir/libhello1
/objdir/libhello1/Makefile
/objdir/libhello1/hello1.c
/objdir/libhello1/hello1.h
@@ -189,31 +184,26 @@ GEN: hello_subprojects2
/objdir/libhello1/libhello1.so.1
/objdir/libhello1/libhello1.so.1.0
/objdir/libhello1/linkme.mk
-/objdir/libhello2
/objdir/libhello2/Makefile
/objdir/libhello2/hello2.3
/objdir/libhello2/hello2.c
-/objdir/libhello2/include
/objdir/libhello2/include/hello2.h
/objdir/libhello2/linkme.mk
/objdir/subprojects.test.out.tmp
/objdir/test.mk
/objdir/version.mk
========= all-libhello2 ==========
-/objdir
/objdir/Makefile
/objdir/_mkc_compiler_type.err
/objdir/_mkc_compiler_type.res
/objdir/_mkc_prog_cc.err
/objdir/_mkc_prog_cc.res
/objdir/expect.out
-/objdir/hello
/objdir/hello/Makefile
/objdir/hello/hello_subprojects.1.in
/objdir/hello/hello_subprojects.c
/objdir/hello/hello_subprojects2.in
/objdir/hello/test.mk
-/objdir/libhello1
/objdir/libhello1/Makefile
/objdir/libhello1/hello1.c
/objdir/libhello1/hello1.h
@@ -224,13 +214,11 @@ GEN: hello_subprojects2
/objdir/libhello1/libhello1.so.1
/objdir/libhello1/libhello1.so.1.0
/objdir/libhello1/linkme.mk
-/objdir/libhello2
/objdir/libhello2/Makefile
/objdir/libhello2/hello2.3
/objdir/libhello2/hello2.c
/objdir/libhello2/hello2.cat3
/objdir/libhello2/hello2.o
-/objdir/libhello2/include
/objdir/libhello2/include/hello2.h
/objdir/libhello2/libhello2.a
/objdir/libhello2/linkme.mk
@@ -238,27 +226,22 @@ GEN: hello_subprojects2
/objdir/test.mk
/objdir/version.mk
========= cleandir-libhello1 ==========
-/objdir
/objdir/Makefile
/objdir/expect.out
-/objdir/hello
/objdir/hello/Makefile
/objdir/hello/hello_subprojects.1.in
/objdir/hello/hello_subprojects.c
/objdir/hello/hello_subprojects2.in
/objdir/hello/test.mk
-/objdir/libhello1
/objdir/libhello1/Makefile
/objdir/libhello1/hello1.c
/objdir/libhello1/hello1.h
/objdir/libhello1/linkme.mk
-/objdir/libhello2
/objdir/libhello2/Makefile
/objdir/libhello2/hello2.3
/objdir/libhello2/hello2.c
/objdir/libhello2/hello2.cat3
/objdir/libhello2/hello2.o
-/objdir/libhello2/include
/objdir/libhello2/include/hello2.h
/objdir/libhello2/libhello2.a
/objdir/libhello2/linkme.mk
diff --git a/examples/subprojects/hello/hello_subprojects.1.in b/examples/subprojects/hello/hello_subprojects.1.in
index 1a4710f..a4fea6d 100644
--- a/examples/subprojects/hello/hello_subprojects.1.in
+++ b/examples/subprojects/hello/hello_subprojects.1.in
@@ -9,7 +9,6 @@ hello\_world \- hello application
.SH DESCRIPTION
.B hello\_world
outputs hello world message to stdout
-
.SH "CONFIGURATION FILE"
.TP
The configuration file should be here
diff --git a/examples/subprojects/test.mk b/examples/subprojects/test.mk
index 1869272..d3b88cc 100644
--- a/examples/subprojects/test.mk
+++ b/examples/subprojects/test.mk
@@ -1,6 +1,8 @@
.PHONY : test_output
test_output :
@set -e; \
+ MKCATPAGES=yes; export MKCATPAGES; \
+ \
echo PROJECTNAME=${PROJECTNAME}; \
rm -rf ${.OBJDIR}${PREFIX}; \
LD_LIBRARY_PATH=${.CURDIR}/libhello1:${.CURDIR}/libhello2:$$LD_LIBRARY_PATH; \
@@ -27,13 +29,13 @@ test_output :
mkc_test_helper "${PREFIX}" "${.OBJDIR}"; \
\
echo ========= install ==========; \
- ${MAKE} ${MAKEFLAGS} install DESTDIR=${.OBJDIR} \
+ ${MAKE} ${MAKEFLAGS} install -j3 DESTDIR=${.OBJDIR} \
> /dev/null; \
find ${.OBJDIR}${PREFIX} -type f -o -type l -o -type d | \
mkc_test_helper "${PREFIX}" "${.OBJDIR}"; \
\
echo ======== uninstall =========; \
- ${MAKE} ${MAKEFLAGS} uninstall DESTDIR=${.OBJDIR} > /dev/null; \
+ ${MAKE} ${MAKEFLAGS} -j4 uninstall DESTDIR=${.OBJDIR} > /dev/null; \
find ${.OBJDIR}${PREFIX} -type f -o -type l | \
mkc_test_helper "${PREFIX}" "${.OBJDIR}";\
\
@@ -55,24 +57,24 @@ test_output :
\
echo ========= libhello1 ==========; \
${MAKE} ${MAKEFLAGS} libhello1 DESTDIR=${.OBJDIR} > /dev/null; \
- find ${.OBJDIR} -type f -o -type l -o -type d | \
+ find ${.OBJDIR} -type f -o -type l | \
mkc_test_helper "${PREFIX}" "${.OBJDIR}"; \
\
echo ========= all-libhello2 ==========; \
- ${MAKE} ${MAKEFLAGS} all-libhello2 DESTDIR=${.OBJDIR} > /dev/null; \
- find ${.OBJDIR} -type f -o -type l -o -type d | \
+ ${MAKE} ${MAKEFLAGS} -j4 all-libhello2 DESTDIR=${.OBJDIR} > /dev/null; \
+ find ${.OBJDIR} -type f -o -type l | \
mkc_test_helper "${PREFIX}" "${.OBJDIR}"; \
\
echo ========= cleandir-libhello1 ==========; \
${MAKE} ${MAKEFLAGS} cleandir-libhello1 DESTDIR=${.OBJDIR} > /dev/null; \
- find ${.OBJDIR} -type f -o -type l -o -type d | \
+ find ${.OBJDIR} -type f -o -type l | \
mkc_test_helper "${PREFIX}" "${.OBJDIR}"; \
\
${MAKE} ${MAKEFLAGS} distclean DESTDIR=${.OBJDIR} > /dev/null; \
\
echo ======= library dependencies =======; \
PREFIX=${.CURDIR}/usr; export PREFIX; \
- ${MAKE} ${MAKEFLAGS} all installdirs install >&2; \
+ ${MAKE} ${MAKEFLAGS} all installdirs install -j3 >&2; \
LD_LIBRARY_PATH=${.CURDIR}/usr/lib; \
DYLD_LIBRARY_PATH=${.CURDIR}/usr/lib; \
export LD_LIBRARY_PATH DYLD_LIBRARY_PATH; \