summaryrefslogtreecommitdiff
path: root/examples/tools/libs/qux/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'examples/tools/libs/qux/Makefile')
-rw-r--r--examples/tools/libs/qux/Makefile16
1 files changed, 16 insertions, 0 deletions
diff --git a/examples/tools/libs/qux/Makefile b/examples/tools/libs/qux/Makefile
new file mode 100644
index 0000000..345f614
--- /dev/null
+++ b/examples/tools/libs/qux/Makefile
@@ -0,0 +1,16 @@
+LIB = qux
+SRCS = qux.c
+INCS = qux.h
+
+MKC_CHECK_SIZEOF = int
+
+.include <mkc.configure.mk>
+
+INFILES = ${INCS}
+INTEXTS_REPLS = int_size ${SIZEOF.int:U4}
+
+qux.o: qux.h
+
+WARNS = 4
+
+.include <mkc.lib.mk>