summaryrefslogtreecommitdiff
path: root/features/mkc_imp.f_SLIST.mk
diff options
context:
space:
mode:
Diffstat (limited to 'features/mkc_imp.f_SLIST.mk')
-rw-r--r--features/mkc_imp.f_SLIST.mk13
1 files changed, 10 insertions, 3 deletions
diff --git a/features/mkc_imp.f_SLIST.mk b/features/mkc_imp.f_SLIST.mk
index de7d2af..c00abc6 100644
--- a/features/mkc_imp.f_SLIST.mk
+++ b/features/mkc_imp.f_SLIST.mk
@@ -2,6 +2,8 @@
#
# See LICENSE file in the distribution.
############################################################
+.include <mkc.configure.mk>
+
_macro = SLIST SIMPLEQ STAILQ LIST TAILQ TAILQ
.for m in ${_macro}
@@ -9,7 +11,8 @@ MKC_CHECK_DEFINES += ${m}_ENTRY:sys/queue.h
_macro.${m} = 1
.endfor
-MKC_NOAUTO=1
+MKC_NOAUTO.orig := ${MKC_NOAUTO}
+MKC_NOAUTO = 1
.include <mkc.configure.mk>
@@ -23,8 +26,12 @@ bad=1
CFLAGS+= -DMKC_SYS_QUEUE_IS_FINE=1
.endif
-.undef bad
-
.for m in ${_macro}
.undef _macro.${m}
.endfor
+
+MKC_NOAUTO := ${MKC_NOAUTO.orig}
+
+.undef bad
+.undef _macro
+.undef MKC_NOAUTO.orig