summaryrefslogtreecommitdiff
path: root/features/mkc_imp.f_err.mk
diff options
context:
space:
mode:
Diffstat (limited to 'features/mkc_imp.f_err.mk')
-rw-r--r--features/mkc_imp.f_err.mk29
1 files changed, 29 insertions, 0 deletions
diff --git a/features/mkc_imp.f_err.mk b/features/mkc_imp.f_err.mk
new file mode 100644
index 0000000..d3b50e1
--- /dev/null
+++ b/features/mkc_imp.f_err.mk
@@ -0,0 +1,29 @@
+# Copyright (c) 2014 by Aleksey Cheusov
+#
+# See LICENSE file in the distribution.
+############################################################
+.ifndef _MKC_IMP_F_ERR_MK
+_MKC_IMP_F_ERR_MK := 1
+
+.include <mkc_imp.f_progname.mk>
+
+.include <mkc_imp.conf-cleanup.mk>
+
+MKC_CHECK_HEADERS += err.h
+MKC_CHECK_FUNCLIBS += err errx verr verrx
+MKC_CHECK_FUNCS3 += err:err.h errx:err.h verr:err.h verrx:err.h
+
+.include <mkc_imp.conf-cleanup.mk>
+
+.if ${HAVE_FUNCLIB.err:U0} && ${HAVE_FUNCLIB.errx:U0} && \
+ ${HAVE_FUNCLIB.verr:U0} && ${HAVE_FUNCLIB.verrx:U0} && \
+ ${HAVE_FUNC3.err.err_h:U0} && ${HAVE_FUNC3.errx.err_h:U0} && \
+ ${HAVE_FUNC3.verr.err_h:U0} && ${HAVE_FUNC3.verrx.err_h:U0}
+CFLAGS += -DMKC_ERR_IS_FINE
+.else
+MKC_SRCS += ${FEATURESDIR}/err/err.c
+.endif
+
+.include <mkc_imp.conf-final.mk>
+
+.endif #_MKC_IMP_F_ERR_MK