summaryrefslogtreecommitdiff
path: root/features/mkc_imp.f_strlcpy.mk
diff options
context:
space:
mode:
Diffstat (limited to 'features/mkc_imp.f_strlcpy.mk')
-rw-r--r--features/mkc_imp.f_strlcpy.mk4
1 files changed, 4 insertions, 0 deletions
diff --git a/features/mkc_imp.f_strlcpy.mk b/features/mkc_imp.f_strlcpy.mk
index 5c41db6..51759a2 100644
--- a/features/mkc_imp.f_strlcpy.mk
+++ b/features/mkc_imp.f_strlcpy.mk
@@ -1,7 +1,11 @@
# Copyright (c) 2014 by Aleksey Cheusov
#
# See LICENSE file in the distribution.
+.ifndef _MKC_IMP_F_STRLCPY_MK
+_MKC_IMP_F_STRLCPY_MK := 1
MKC_SOURCE_FUNCLIBS += strlcpy
MKC_SOURCE_DIR.strlcpy.c = ${FEATURESDIR}/strlcpy
MKC_CHECK_FUNCS3 += strlcpy:string.h
+
+.endif #_MKC_IMP_F_STRLCPY_MK