summaryrefslogtreecommitdiff
path: root/main.mk
diff options
context:
space:
mode:
Diffstat (limited to 'main.mk')
-rw-r--r--main.mk17
1 files changed, 12 insertions, 5 deletions
diff --git a/main.mk b/main.mk
index b7eff3e..45ed6a5 100644
--- a/main.mk
+++ b/main.mk
@@ -1,15 +1,20 @@
+# Copyright (c) 2014 by Aleksey Cheusov
+#
+# See LICENSE file in the distribution.
+############################################################
+
.sinclude "cheusov_local_settings.mk" # for debugging
##################################################
-SUBPRJ_DFLT = custom helpers mk scripts features
-SUBPRJ = examples doc presentation ${SUBPRJ_DFLT}
+SUBPRJ_DFLT = builtins helpers mk scripts features doc
+SUBPRJ = examples presentation ${SUBPRJ_DFLT}
tests = configure_test mkinstall mkshlib mkstaticlib mkpiclib \
mkprofilelib mkdll pkg_config_0 pkg_config_1 pkg_config_1_1 pkg_config_2 \
lua_dirs rec_makefiles reqd reqd2 reqd3 reqd4 reqd_clean_cache \
intexts_cleantrg require_prototype test_subprj_dash test_mkc_vs_PROG \
test_mkc_vs_LIB test_mkc_vs_SUBDIR test_mkc_vs_SUBPRJ endianess \
- create_cachedir sys_queue predopost_targets
+ create_cachedir sys_queue predopost_targets FSRCDIR
.for t in ${tests}
SUBPRJ += tests/${t}:tests
.endfor
@@ -20,7 +25,9 @@ examples = hello_world hello_scripts hello_files hello_sizeof hello_lex \
hello_strlcpy3 hello_customtests hello_customtests2 hello_requirements \
hello_iconv hello_cxx hello_cxxlib hello_dictd hello_lua hello_lua2 \
hello_lua3 hello_superfs hello_xxzip hello_progs hello_progs2 tools \
- tools2 pkgconfig3 hello_SLIST hello_RBTREE # hello_require_tools
+ tools2 pkgconfig3 hello_SLIST hello_RBTREE hello_errwarn hello_fgetln \
+ hello_autotools hello_autoconf hello_libdeps hello_compatlib \
+ hello_require_tools
.for t in ${examples}
SUBPRJ += examples/${t}:tests
.endfor
@@ -36,7 +43,7 @@ NOEXPORT_VARNAMES = MKC_CACHEDIR
DIST_TARGETS = pdf clean-mk clean-scripts mkc_clean
INSTALL = ${.CURDIR}/scripts/mkc_install
-PATH := ${OBJDIR_custom}:${OBJDIR_helpers}:${.CURDIR}/helpers:${OBJDIR_scripts}:${.CURDIR}/scripts:${PATH}
+PATH := ${OBJDIR_builtins}:${OBJDIR_helpers}:${.CURDIR}/helpers:${OBJDIR_scripts}:${.CURDIR}/scripts:${PATH}
.export SHRTOUT INSTALL PATH