summaryrefslogtreecommitdiff
path: root/mk/mkc_imp.man.mk
diff options
context:
space:
mode:
Diffstat (limited to 'mk/mkc_imp.man.mk')
-rw-r--r--mk/mkc_imp.man.mk16
1 files changed, 7 insertions, 9 deletions
diff --git a/mk/mkc_imp.man.mk b/mk/mkc_imp.man.mk
index 15203d4..c66f056 100644
--- a/mk/mkc_imp.man.mk
+++ b/mk/mkc_imp.man.mk
@@ -34,7 +34,7 @@ MKCATPAGES = no
.PHONY: catinstall maninstall catpages manpages catlinks \
manlinks html installhtml
.if ${MKMAN:tl} != "no"
-realinstall: ${MANINSTALL}
+do_install1: ${MANINSTALL}
.endif
MANTARGET ?= cat
@@ -68,7 +68,7 @@ TBL ?= tbl
.endif
.if defined(MAN) && !empty(MAN)
-realall: ${MAN}
+realdo_all: ${MAN}
MANPAGES = ${MAN}
CATPAGES = ${MANPAGES:C/(.*).([1-9])/\1.cat\2/}
CLEANFILES += ${CATPAGES}
@@ -77,7 +77,7 @@ HTMLPAGES = ${MANPAGES:C/(.*).([1-9])/\1.html\2/}
.endif
MINSTALL = ${INSTALL} ${RENAME} ${PRESERVE} ${COPY} \
- -o ${MANOWN} -g ${MANGRP} -m ${MANMODE}
+ -o ${MANOWN:Q} -g ${MANGRP:Q} -m ${MANMODE}
.if defined(MANZ)
# chown and chmod are done afterward automatically
@@ -92,7 +92,7 @@ __installpage: .USE
.if defined(MCOMPRESS) && !empty(MCOMPRESS)
@${RM} -f ${.TARGET}
${MCOMPRESS} ${.ALLSRC} > ${.TARGET}
- @chown ${MANOWN}:${MANGRP} ${.TARGET}
+ @chown ${MANOWN:Q}:${MANGRP:Q} ${.TARGET}
@chmod ${MANMODE} ${.TARGET}
.else
${MINSTALL} ${.ALLSRC} ${.TARGET}
@@ -101,7 +101,7 @@ __installpage: .USE
# Rules for cat'ed man page installation
.if defined(CATPAGES) && !empty(CATPAGES) && ${MKCATPAGES:tl} != "no"
-realall: ${CATPAGES}
+realdo_all: ${CATPAGES}
.if ${MKINSTALL:tl} == "yes"
destination_capages = ${CATPAGES:@P@${DESTDIR}${MANDIR}/${P:T:E}${MANSUBDIR}/${P:T:R}.0${MCOMPRESSSUFFIX}@}
@@ -177,13 +177,11 @@ installhtml: ${destination_htmls}
CLEANFILES += ${HTMLPAGES}
.if ${MKHTML:tl} == "yes"
-realinstall: installhtml
-realall: ${HTMLPAGES}
+do_install1: installhtml
+realdo_all: ${HTMLPAGES}
UNINSTALLFILES += ${destination_htmls}
INSTALLDIRS += ${destination_htmls:H}
.endif # MKHTML
.endif # HTMLPAGES
-realall:
-
.endif # _MKC_IMP_MAN_MK