summaryrefslogtreecommitdiff
path: root/mk/mkc_imp.platform.sys.mk
diff options
context:
space:
mode:
Diffstat (limited to 'mk/mkc_imp.platform.sys.mk')
-rw-r--r--mk/mkc_imp.platform.sys.mk4
1 files changed, 3 insertions, 1 deletions
diff --git a/mk/mkc_imp.platform.sys.mk b/mk/mkc_imp.platform.sys.mk
index 90fee7f..7fb81c4 100644
--- a/mk/mkc_imp.platform.sys.mk
+++ b/mk/mkc_imp.platform.sys.mk
@@ -320,11 +320,13 @@ LDFLAGS.soname.sunpro = ${LDFLAGS.soname.sunld}
.if ${TARGET_OPSYS:Unone} == "Darwin"
.if ${MKDLL:U} == "no"
LDFLAGS.shared.gcc.Darwin = -dynamiclib -install_name ${LIBDIR}/lib${LIB}${SHLIB_EXTFULL}
+LDFLAGS.shared.clang.Darwin = -dynamiclib -install_name ${LIBDIR}/lib${LIB}${SHLIB_EXTFULL}
SHLIB_MAJORp1 != expr 1 + ${SHLIB_MAJOR:U0}
LDFLAGS.soname.gcc = -current_version ${SHLIB_MAJORp1}${SHLIB_MINOR:D.${SHLIB_MINOR}}${SHLIB_TEENY:D.${SHLIB_TEENY}}
LDFLAGS.soname.gcc += -compatibility_version ${SHLIB_MAJORp1}
.else
LDFLAGS.shared.gcc.Darwin = -flat_namespace -bundle -undefined suppress
+LDFLAGS.shared.clang.Darwin = -flat_namespace -bundle -undefined suppress
.endif
.elif ${TARGET_OPSYS:Unone} == "OSF1" && defined(LIB)
CLEANFILES += ${.OBJDIR}/${LIB}_so_locations
@@ -371,7 +373,7 @@ LDFLAGS.relro := ${LDFLAGS.relro:S/^/-Wl,/g}
.if ${TARGET_OPSYS:Unone} == "Darwin"
COMPILE.s ?= ${AS} ${AFLAGS}
-COMPILE.S ?= ${CC} ${AFLAGS} ${CPPFLAGS} -c
+COMPILE.S ?= ${CC} ${AFLAGS} ${_CPPFLAGS} -c
.if ${MKDLL:U} != "no"