summaryrefslogtreecommitdiff
path: root/tests/intexts_cleantrg/test.mk
diff options
context:
space:
mode:
Diffstat (limited to 'tests/intexts_cleantrg/test.mk')
-rw-r--r--tests/intexts_cleantrg/test.mk26
1 files changed, 26 insertions, 0 deletions
diff --git a/tests/intexts_cleantrg/test.mk b/tests/intexts_cleantrg/test.mk
new file mode 100644
index 0000000..c1964a5
--- /dev/null
+++ b/tests/intexts_cleantrg/test.mk
@@ -0,0 +1,26 @@
+.PHONY : test_output
+test_output :
+ @set -e; \
+ \
+ echo =========== all ============; \
+ find ${.OBJDIR} -type f -o -type l | \
+ mkc_test_helper "${PREFIX}" "${.OBJDIR}"; \
+ \
+ echo ========== clean ===========; \
+ ${MAKE} ${MAKEFLAGS} clean DESTDIR=${.OBJDIR} > /dev/null; \
+ find ${.OBJDIR} -type f -o -type l | \
+ mkc_test_helper "${PREFIX}" "${.OBJDIR}"; \
+ \
+ echo ======= distclean ==========; \
+ ${MAKE} ${MAKEFLAGS} distclean > /dev/null; \
+ find ${.OBJDIR} -type f -o -type l | \
+ mkc_test_helper "${PREFIX}" "${.OBJDIR}"; \
+ \
+ echo ======= cleandir ==========; \
+ ${MAKE} ${MAKEFLAGS} distclean > /dev/null; \
+ find ${.OBJDIR} -type f -o -type l | \
+ mkc_test_helper "${PREFIX}" "${.OBJDIR}"; \
+ \
+ ${MAKE} ${MAKEFLAGS} cleandir > /dev/null
+
+.include <mkc.minitest.mk>