summaryrefslogtreecommitdiff
path: root/tests/reqd_clean_cache/test.mk
diff options
context:
space:
mode:
Diffstat (limited to 'tests/reqd_clean_cache/test.mk')
-rw-r--r--tests/reqd_clean_cache/test.mk14
1 files changed, 14 insertions, 0 deletions
diff --git a/tests/reqd_clean_cache/test.mk b/tests/reqd_clean_cache/test.mk
new file mode 100644
index 0000000..e5cea19
--- /dev/null
+++ b/tests/reqd_clean_cache/test.mk
@@ -0,0 +1,14 @@
+TEST_PREREQS = # empty
+
+.PHONY : test_output
+test_output :
+ @set -e; LC_ALL=C; export LC_ALL; \
+ \
+ echo =========== all ============; \
+ { ${MAKE} ${MAKEFLAGS} all 2>/dev/null || true; \
+ find ${.OBJDIR} -type f -o -type l | sort; } | \
+ env NOSORT=1 mkc_test_helper "${PREFIX}" "${.OBJDIR}"; \
+ \
+ ${MAKE} ${MAKEFLAGS} cleandir > /dev/null
+
+.include <mkc.minitest.mk>