summaryrefslogtreecommitdiff
path: root/tests/test_subprj_dash/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'tests/test_subprj_dash/Makefile')
-rw-r--r--tests/test_subprj_dash/Makefile14
1 files changed, 14 insertions, 0 deletions
diff --git a/tests/test_subprj_dash/Makefile b/tests/test_subprj_dash/Makefile
new file mode 100644
index 0000000..532832d
--- /dev/null
+++ b/tests/test_subprj_dash/Makefile
@@ -0,0 +1,14 @@
+CLEANFILES += ${.OBJDIR}/${.CURDIR:T}.test.out
+
+test:
+ @echo 'Testing ${.CURDIR}... ' 1>&2; \
+ set -e; \
+ tmp_out=${.OBJDIR}/${.CURDIR:T}.test.out; \
+ rm -f $$tmp_out; \
+ ${MAKE} ${MAKEFLAGS} -f ${.CURDIR}/test.mk all 2>&1 | \
+ mkc_test_helper "${PREFIX}" "${.OBJDIR}" > $$tmp_out; \
+ diff ${.CURDIR}/expect.out $$tmp_out && \
+ echo ' succeeded' 1>&2 || \
+ { echo ' FAILED' 1>&2; false; }
+
+.include <mkc.subprj.mk>