summaryrefslogtreecommitdiff
path: root/tests/test_subprj_dash
diff options
context:
space:
mode:
Diffstat (limited to 'tests/test_subprj_dash')
-rw-r--r--tests/test_subprj_dash/Makefile14
-rw-r--r--tests/test_subprj_dash/expect.out1
-rw-r--r--tests/test_subprj_dash/test.mk3
3 files changed, 18 insertions, 0 deletions
diff --git a/tests/test_subprj_dash/Makefile b/tests/test_subprj_dash/Makefile
new file mode 100644
index 0000000..532832d
--- /dev/null
+++ b/tests/test_subprj_dash/Makefile
@@ -0,0 +1,14 @@
+CLEANFILES += ${.OBJDIR}/${.CURDIR:T}.test.out
+
+test:
+ @echo 'Testing ${.CURDIR}... ' 1>&2; \
+ set -e; \
+ tmp_out=${.OBJDIR}/${.CURDIR:T}.test.out; \
+ rm -f $$tmp_out; \
+ ${MAKE} ${MAKEFLAGS} -f ${.CURDIR}/test.mk all 2>&1 | \
+ mkc_test_helper "${PREFIX}" "${.OBJDIR}" > $$tmp_out; \
+ diff ${.CURDIR}/expect.out $$tmp_out && \
+ echo ' succeeded' 1>&2 || \
+ { echo ' FAILED' 1>&2; false; }
+
+.include <mkc.subprj.mk>
diff --git a/tests/test_subprj_dash/expect.out b/tests/test_subprj_dash/expect.out
new file mode 100644
index 0000000..e23e0e3
--- /dev/null
+++ b/tests/test_subprj_dash/expect.out
@@ -0,0 +1 @@
+Dash symbol is not allowed inside subdir (another-one prog100-500)
diff --git a/tests/test_subprj_dash/test.mk b/tests/test_subprj_dash/test.mk
new file mode 100644
index 0000000..7ba6a8f
--- /dev/null
+++ b/tests/test_subprj_dash/test.mk
@@ -0,0 +1,3 @@
+SUBPRJ = prog prog100-500 liba another-one
+
+.include <mkc.subprj.mk>