summaryrefslogtreecommitdiff
path: root/debian
diff options
context:
space:
mode:
authorFelipe Sateler <fsateler@debian.org>2016-10-05 20:50:16 -0300
committerFelipe Sateler <fsateler@debian.org>2016-10-05 20:50:16 -0300
commitaa05ae1c2a2f400847138e9fa97d178f1904ba73 (patch)
tree7881305802bbb1ef766636ce62ed282f8501fdff /debian
parent5adfa67b2ae9c7b35cf1bf1d8227fa6e121c2aa6 (diff)
Create manpage via help2man
Diffstat (limited to 'debian')
-rw-r--r--debian/clean1
-rw-r--r--debian/control1
-rw-r--r--debian/manpages1
-rwxr-xr-xdebian/rules11
4 files changed, 13 insertions, 1 deletions
diff --git a/debian/clean b/debian/clean
new file mode 100644
index 0000000..7bd2ebd
--- /dev/null
+++ b/debian/clean
@@ -0,0 +1 @@
+debian/mkosi.1
diff --git a/debian/control b/debian/control
index 4aa25ce..e59e7e3 100644
--- a/debian/control
+++ b/debian/control
@@ -5,6 +5,7 @@ Section: admin
Priority: optional
Build-Depends: debhelper (>= 10),
dh-python,
+ help2man,
python3-all,
python3-setuptools
Standards-Version: 3.9.8
diff --git a/debian/manpages b/debian/manpages
new file mode 100644
index 0000000..7bd2ebd
--- /dev/null
+++ b/debian/manpages
@@ -0,0 +1 @@
+debian/mkosi.1
diff --git a/debian/rules b/debian/rules
index 8f5bf9c..523b72a 100755
--- a/debian/rules
+++ b/debian/rules
@@ -2,13 +2,22 @@
#export DH_VERBOSE = 1
+include /usr/share/dpkg/pkg-info.mk
+
export PYBUILD_NAME=mkosi
%:
dh $@ --with python3 --buildsystem=pybuild
# need explicit target to be able to mark as phony
-build:
+build: debian/mkosi.1
dh $@ --with python3 --buildsystem=pybuild
+debian/mkosi.1:
+ help2man --name "Create legacy-free OS images" \
+ --version-string "mkosi $(DEB_VERSION_UPSTREAM)" \
+ --no-info \
+ -o debian/mkosi.1 \
+ ./mkosi
+
.PHONY: build