summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--debian/changelog26
-rw-r--r--debian/clean1
-rw-r--r--debian/compat1
-rw-r--r--debian/control35
-rw-r--r--debian/copyright28
-rw-r--r--debian/docs1
-rw-r--r--debian/gbp.conf8
-rw-r--r--debian/manpages1
-rwxr-xr-xdebian/rules23
-rw-r--r--debian/source/format1
-rw-r--r--debian/source/options1
-rw-r--r--debian/watch7
12 files changed, 133 insertions, 0 deletions
diff --git a/debian/changelog b/debian/changelog
new file mode 100644
index 0000000..d5e0660
--- /dev/null
+++ b/debian/changelog
@@ -0,0 +1,26 @@
+mkosi (1-1) unstable; urgency=medium
+
+ * First upstream release
+
+ -- Felipe Sateler <fsateler@debian.org> Sun, 06 Nov 2016 19:28:47 -0300
+
+mkosi (0~20161012-1) unstable; urgency=medium
+
+ * New upstream git snapshot
+ * Also hook up debian/mkosi.1 for build-indep builds (Closes: #840425)
+
+ -- Felipe Sateler <fsateler@debian.org> Wed, 19 Oct 2016 12:27:32 -0300
+
+mkosi (0~20161004-1) unstable; urgency=medium
+
+ * New upstream git snapshot
+ * Create manpage via help2man
+
+ -- Felipe Sateler <fsateler@debian.org> Wed, 05 Oct 2016 20:50:54 -0300
+
+mkosi (0~20160922-1) unstable; urgency=medium
+
+ * Initial release (Closes: #833804)
+ - No upstream release yet, so git commit 893397862b2
+
+ -- Felipe Sateler <fsateler@debian.org> Sun, 25 Sep 2016 12:56:26 -0300
diff --git a/debian/clean b/debian/clean
new file mode 100644
index 0000000..7bd2ebd
--- /dev/null
+++ b/debian/clean
@@ -0,0 +1 @@
+debian/mkosi.1
diff --git a/debian/compat b/debian/compat
new file mode 100644
index 0000000..f599e28
--- /dev/null
+++ b/debian/compat
@@ -0,0 +1 @@
+10
diff --git a/debian/control b/debian/control
new file mode 100644
index 0000000..e59e7e3
--- /dev/null
+++ b/debian/control
@@ -0,0 +1,35 @@
+Source: mkosi
+Maintainer: Debian systemd Maintainers <pkg-systemd-maintainers@lists.alioth.debian.org>
+Uploaders: Felipe Sateler <fsateler@debian.org>
+Section: admin
+Priority: optional
+Build-Depends: debhelper (>= 10),
+ dh-python,
+ help2man,
+ python3-all,
+ python3-setuptools
+Standards-Version: 3.9.8
+Homepage: https://github.com/systemd/mkosi
+Vcs-Git: https://anonscm.debian.org/git/pkg-systemd/mkosi.git
+Vcs-Browser: https://anonscm.debian.org/cgit/pkg-systemd/mkosi.git/
+X-Python3-Version: >= 3.2
+
+Package: mkosi
+Architecture: all
+Depends: btrfs-progs,
+ dosfstools,
+ xz-utils,
+ debootstrap,
+ systemd-container,
+ ${misc:Depends},
+ ${python3:Depends}
+Recommends: ovmf
+Description: create legacy-free OS images
+ A fancy wrapper around "dnf --installroot", "debootstrap" and
+ "pacstrap", that may generate disk images with a number of
+ bells and whistles.
+ .
+ Generated images are "legacy-free". This means only GPT disk
+ labels (and no MBR disk labels) are supported, and only
+ systemd based images may be generated. Moreover, for bootable
+ images only EFI systems are supported (not plain MBR/BIOS).
diff --git a/debian/copyright b/debian/copyright
new file mode 100644
index 0000000..f614ba3
--- /dev/null
+++ b/debian/copyright
@@ -0,0 +1,28 @@
+Format: https://www.debian.org/doc/packaging-manuals/copyright-format/1.0/
+Upstream-Name: mkosi
+Source: https://github.com/systemd/mkosi
+
+Files: *
+Copyright: 2016 Lennart Poettering <lennart@poettering.net>
+License: LGPL-2.1
+
+Files: debian/*
+Copyright: 2016 Felipe Sateler <fsateler@debian.org>
+License: LGPL-2.1
+
+License: LGPL-2.1
+ This package is free software; you can redistribute it and/or
+ modify it under the terms of the GNU Lesser General Public
+ License as published by the Free Software Foundation;
+ version 2.1 of the License.
+ .
+ This package is distributed in the hope that it will be useful,
+ but WITHOUT ANY WARRANTY; without even the implied warranty of
+ MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the GNU
+ Lesser General Public License for more details.
+ .
+ You should have received a copy of the GNU Lesser General Public License
+ along with this program. If not, see <https://www.gnu.org/licenses/>.
+ .
+ On Debian systems, the complete text of the GNU Lesser General
+ Public License can be found in "/usr/share/common-licenses/LGPL-2".
diff --git a/debian/docs b/debian/docs
new file mode 100644
index 0000000..b43bf86
--- /dev/null
+++ b/debian/docs
@@ -0,0 +1 @@
+README.md
diff --git a/debian/gbp.conf b/debian/gbp.conf
new file mode 100644
index 0000000..6dc3643
--- /dev/null
+++ b/debian/gbp.conf
@@ -0,0 +1,8 @@
+[DEFAULT]
+pristine-tar = True
+patch-numbers = False
+debian-branch = master
+
+[dch]
+full = True
+multimaint-merge = True
diff --git a/debian/manpages b/debian/manpages
new file mode 100644
index 0000000..7bd2ebd
--- /dev/null
+++ b/debian/manpages
@@ -0,0 +1 @@
+debian/mkosi.1
diff --git a/debian/rules b/debian/rules
new file mode 100755
index 0000000..b610a2d
--- /dev/null
+++ b/debian/rules
@@ -0,0 +1,23 @@
+#!/usr/bin/make -f
+
+#export DH_VERBOSE = 1
+
+include /usr/share/dpkg/pkg-info.mk
+
+export PYBUILD_NAME=mkosi
+
+%:
+ dh $@ --with python3 --buildsystem=pybuild
+
+# need explicit target to be able to mark as phony
+build build-indep: debian/mkosi.1
+ dh $@ --with python3 --buildsystem=pybuild
+
+debian/mkosi.1:
+ help2man --name "Create legacy-free OS images" \
+ --version-string "mkosi $(DEB_VERSION_UPSTREAM)" \
+ --no-info \
+ -o debian/mkosi.1 \
+ ./mkosi
+
+.PHONY: build
diff --git a/debian/source/format b/debian/source/format
new file mode 100644
index 0000000..163aaf8
--- /dev/null
+++ b/debian/source/format
@@ -0,0 +1 @@
+3.0 (quilt)
diff --git a/debian/source/options b/debian/source/options
new file mode 100644
index 0000000..50032e0
--- /dev/null
+++ b/debian/source/options
@@ -0,0 +1 @@
+extend-diff-ignore=mkosi\.egg-info/
diff --git a/debian/watch b/debian/watch
new file mode 100644
index 0000000..aca3482
--- /dev/null
+++ b/debian/watch
@@ -0,0 +1,7 @@
+# Compulsory line, this is a version 4 file
+version=4
+
+opts="filenamemangle=s%(?:.*?)?v?(\d[\d.]*)\.tar\.gz%mkosi-$1.tar.gz%" \
+ https://github.com/systemd/mkosi/tags \
+ (?:.*?/)?v?(\d[\d.]*)\.tar\.gz debian uupdate
+