summaryrefslogtreecommitdiff
path: root/rules
diff options
context:
space:
mode:
Diffstat (limited to 'rules')
-rwxr-xr-xrules19
1 files changed, 19 insertions, 0 deletions
diff --git a/rules b/rules
new file mode 100755
index 0000000..1733887
--- /dev/null
+++ b/rules
@@ -0,0 +1,19 @@
+#!/usr/bin/make -f
+
+#export DH_VERBOSE = 1
+
+include /usr/share/dpkg/pkg-info.mk
+
+export PYBUILD_NAME=mkosi
+
+%:
+ dh $@ --with python3 --buildsystem=pybuild
+
+# need explicit target to be able to mark as phony
+override_dh_auto_build:
+ dh_auto_build --buildsystem=pybuild
+ help2man --name "Create legacy-free OS images" \
+ --version-string "mkosi $(DEB_VERSION_UPSTREAM)" \
+ --no-info \
+ -o debian/mkosi.1 \
+ ./mkosi