summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSasa Bodiroza <jazzva@gmail.com>2009-09-07 16:36:52 +0200
committerSasa Bodiroza <jazzva@gmail.com>2009-09-07 16:36:52 +0200
commit085aed18edb036df879c584375214b974cc8bc7c (patch)
tree5522713838becd1ddb7ab401f5f9e629f2322633
parent1b90b2ea10d7a0bed4a79faae0647be818f4e891 (diff)
parent4530d7c44c15e2d2c3e9c1a45c073508c48b004c (diff)
(merge lp:~bdrung/mozilla-devscripts/mxdlf)
- Guess common license file names if MOZ_XPI_DOCUMENTED_LICENSE_FILES is not set. - update src/xpi.mk
-rw-r--r--debian/changelog5
-rw-r--r--src/xpi.mk5
2 files changed, 8 insertions, 2 deletions
diff --git a/debian/changelog b/debian/changelog
index 27fc9b5..439acb7 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -9,8 +9,11 @@ mozilla-devscripts (0.16) UNRELEASED; urgency=low
- rename stamp-* targets to *-stamp, merge stamp-extension-install into
xpi-install, merge xpi-clean into clean
- update src/xpi.mk
+ - Guess common license file names if MOZ_XPI_DOCUMENTED_LICENSE_FILES is
+ not set.
+ - update src/xpi.mk
- -- Benjamin Drung <bdrung@ubuntu.com> Sat, 22 Aug 2009 17:11:36 +0200
+ -- Benjamin Drung <bdrung@ubuntu.com> Sun, 23 Aug 2009 00:24:04 +0200
mozilla-devscripts (0.15) unstable; urgency=low
diff --git a/src/xpi.mk b/src/xpi.mk
index f065915..842d527 100644
--- a/src/xpi.mk
+++ b/src/xpi.mk
@@ -56,7 +56,8 @@
# defines extra license files which need to be excluded during
# the installation of the XPI file to the packaging tree. When
# using parameter, be sure that you documented _all_ excluded
-# license files in debian/copyright appropriately
+# license files in debian/copyright appropriately. If not defined
+# the common license file names are tried.
#
# Deprecated variables:
#
@@ -147,6 +148,8 @@ MOZ_EXTENSION_PKG ?= $(strip $(shell grep ^Package: debian/control | head -n 1 |
MOZ_XPI_BUILD_COMMAND ?= med-xpi-pack $(CURDIR) $(MOZ_EXTENSION_PKG).xpi;
+MOZ_XPI_DOCUMENTED_LICENSE_FILES ?= $(strip $(shell find * -iname copying -o -iname licen[cs]e -o -iname licen[cs]e.txt))
+
XPI_DEPENDS = $(sort $(foreach id,$(call XPI_TARGET_EMIDs,$(TEMPDIR)), \
$(foreach package,$(packages_$(id)),$(call CHECK_VERSION,$(id),$(package)))))