summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBenjamin Drung <bdrung@ubuntu.com>2009-10-06 02:50:38 +0200
committerBenjamin Drung <bdrung@ubuntu.com>2009-10-06 02:50:38 +0200
commit0b010ce323053e259880a980fd95026bac36b9db (patch)
tree2769e16e47878fcabbc67c91fbc578574423764e
parent1989a55a6ec1198217a6018663bae4bf92696d98 (diff)
- support different types of install.rdf files (LP: #442897)
- update src/xpi.mk
-rw-r--r--debian/changelog4
-rw-r--r--src/xpi.mk4
2 files changed, 5 insertions, 3 deletions
diff --git a/debian/changelog b/debian/changelog
index f617c7a..4364b33 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -8,8 +8,10 @@ mozilla-devscripts (0.17) UNRELEASED; urgency=low
- update src/xpi.mk
- Fail to build, if the extension manager ID could not be detected.
- update src/xpi.mk
+ - support different types of install.rdf files (LP: #442897)
+ - update src/xpi.mk
- -- Benjamin Drung <bdrung@ubuntu.com> Tue, 06 Oct 2009 02:34:26 +0200
+ -- Benjamin Drung <bdrung@ubuntu.com> Tue, 06 Oct 2009 02:49:21 +0200
mozilla-devscripts (0.16) unstable; urgency=low
diff --git a/src/xpi.mk b/src/xpi.mk
index 9385a03..a1f4925 100644
--- a/src/xpi.mk
+++ b/src/xpi.mk
@@ -194,7 +194,7 @@ ifneq (,$(MOZ_XPI_EMID))
XPI_EMID = $(MOZ_XPI_EMID)
else
XPI_EMID = $(sort $(shell xpath -q -e '/node()/Description/em:id/text() | //RDF:Description[@RDF:about="urn:mozilla:install-manifest"]/em:id/text()' $(1)/install.rdf 2>/dev/null) \
- $(shell xpath -q -e '//RDF:Description[@RDF:about="urn:mozilla:install-manifest"]/@em:id' $(1)/install.rdf 2>/dev/null | sed -e 's/.*"\(.*\)"/\1/'))
+ $(shell xpath -q -e '/node()/Description/@em:id | //RDF:Description[@RDF:about="urn:mozilla:install-manifest"]/@em:id' $(1)/install.rdf 2>/dev/null | sed -e 's/.*"\(.*\)"/\1/'))
endif
ifeq (,$(MOZ_XPI_DISABLE_AUTOLINKS))
@@ -249,7 +249,7 @@ autolinks-stamp: $(patsubst %,unzip-%-stamp,$(XPI_BASE_FILE)) $(foreach mozilla,
$(if $(XPI_FILE),,@echo "xpi.mk: No xpi file found. Did you create one?"; \
echo "xpi.mk: Please check MOZ_XPI_BUILD_COMMAND and maybe MOZ_XPI_FILE!"; \
exit 2)
- $(if $(XPI_EMID),,@echo "xpi.mk: Detecting the extension manager ID failed."; \
+ $(if $(call XPI_EMID,$(TEMPDIR)),,@echo "xpi.mk: Detecting the extension manager ID failed."; \
echo "xpi.mk: This is either a bug in the install.rdf file or in mozilla-devscripts."; \
echo "xpi.mk: Patch the install.rdf file or use MOZ_XPI_EMID as workaround."; \
exit 3)