summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorFabien Tassin <fta@sofaraway.org>2008-05-25 19:38:06 +0200
committerFabien Tassin <fta@sofaraway.org>2008-05-25 19:38:06 +0200
commit15cbcbcf0fb01a256e7281d27040d1a909b085cc (patch)
tree88c403310c99baee985562961e1e2cc532baeedb
parente05c8dc44e5a8c75ac7f1e36fbe3738d050442bf (diff)
* [mozclient] add projects xulrunner-1.9.1 and firefox-3.1 using Mercurial
- add src/firefox-3.1.mk.in - add src/xulrunner-1.9.1.mk.in - update src/Makefile - update README
-rw-r--r--README4
-rw-r--r--debian/changelog5
-rw-r--r--src/Makefile2
-rw-r--r--src/firefox-3.1.mk.in69
-rw-r--r--src/xulrunner-1.9.1.mk.in62
5 files changed, 141 insertions, 1 deletions
diff --git a/README b/README
index 7e3f5b8..3a5a518 100644
--- a/README
+++ b/README
@@ -14,6 +14,8 @@ usable by Mozilla packages in Ubuntu.
The package contains rules for the following projects:
- firefox-3.0
+ - firefox-3.1
+ - firefox-4.0
- lightning-sunbird (from MOZILLA_1_8_BRANCH)
- nspr
- nss
@@ -22,6 +24,8 @@ The package contains rules for the following projects:
- thunderbird-3.0
- xulrunner (1.8, from MOZILLA_1_8_BRANCH)
- xulrunner-1.9
+ - xulrunner-1.9.1
+ - xulrunner-2.0
In addition there is a xpi.mk which provides standard rules/targets to package
XPI extensions for mozilla/toolkit based applications.
diff --git a/debian/changelog b/debian/changelog
index f2f37ed..5304b5d 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -33,7 +33,10 @@ mozilla-devscripts (0.08) UNRELEASED; urgency=low
- update deban/control
- add src/firefox-4.0.mk.in
- update src/Makefile
- + add project xulrunner-2.0 also using Mercurial
+ + add projects xulrunner-2.0, xulrunner-1.9.1 and firefox-3.1, also using
+ Mercurial
+ - add src/firefox-3.1.mk.in
+ - add src/xulrunner-1.9.1.mk.in
- add src/xulrunner-2.0.mk.in
- update src/Makefile
+ add a variable called DEBIAN_KEEP_VCS to preserve the VCS files such as
diff --git a/src/Makefile b/src/Makefile
index c97d58b..31dd5da 100644
--- a/src/Makefile
+++ b/src/Makefile
@@ -24,6 +24,7 @@ DATADIR = $(PREFIX)/share/mozilla-devscripts
mk_files = \
firefox-3.0.mk \
firefox-3.0-full.mk \
+ firefox-3.1.mk \
firefox-4.0.mk \
lightning-sunbird.mk \
nspr.mk \
@@ -32,6 +33,7 @@ mk_files = \
thunderbird-3.0.mk \
xulrunner-1.8.mk \
xulrunner-1.9.mk \
+ xulrunner-1.9.1.mk \
xulrunner-2.0.mk \
mozclient.mk \
compare.mk \
diff --git a/src/firefox-3.1.mk.in b/src/firefox-3.1.mk.in
new file mode 100644
index 0000000..000e39d
--- /dev/null
+++ b/src/firefox-3.1.mk.in
@@ -0,0 +1,69 @@
+# -*- mode: makefile; coding: utf-8 -*-
+
+# Copyright (c) 2008 Fabien Tassin <fta@sofaraway.org>
+# Description: Project firefox 3.1
+#
+# This program is free software; you can redistribute it and/or
+# modify it under the terms of the GNU General Public License as
+# published by the Free Software Foundation; either version 2, or (at
+# your option) any later version.
+#
+# This program is distributed in the hope that it will be useful, but
+# WITHOUT ANY WARRANTY; without even the implied warranty of
+# MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the GNU
+# General Public License for more details.
+#
+# You should have received a copy of the GNU General Public License along
+# with this program; if not, write to the Free Software Foundation, Inc.,
+# 51 Franklin Street, Fifth Floor, Boston, MA 02110-1301 USA.
+
+MOZCLIENT_TARGET := firefox-3.1-orig
+MOZCLIENT_APPNAME := firefox-3.1
+MOZCLIENT_PROJECT := mozilla-central
+MOZCLIENT_FILE := mozilla/browser/config/version.txt
+MOZCLIENT_GETVERSION := sed -e 's/pre//; s/\([ab]\)\([0-9]*\)/~\1\2/' $(MOZCLIENT_FILE)
+MOZCLIENT_VCS := hg
+MOZCLIENT_POSTCOCMD := cd mozilla && python client.py checkout
+MOZCLIENT_URL := http://hg.mozilla.org/index.cgi/$(MOZCLIENT_PROJECT)/log
+MOZCLIENT_GETDATE = wget -O - -q --read-timeout=10 --user-agent='' --tries=3 $(MOZCLIENT_URL) 2> /dev/null | \
+ grep cite | head -1 | sed -e 's,.*</cite>,,' | \
+ perl -e '$$m = { "Jan" => 1, "Feb" => 2, "Mar" => 3, "Apr" => 4, "May" => 5, "Jun" => 6, \
+ "Jul" => 7, "Aug" => 8, "Sep" => 9, "Oct" => 10, "Nov" => 11, "Dec" => 12 } ; $$a = <>; \
+ $$a =~ m/^ - \S+,\s+(\d+) (\S+) (\d+) \S+ \S+ - rev (\d+)/ && do { \
+ printf "%d~%04d%02d%02d\n", $$4, $$3, $$$$m{$$2}, $$1 }; '
+MOZCLIENT_EMBEDDED := 1
+MOZCLIENT_WANTMOZDIR := 1
+
+include mozclient.mk.in
+
+COMPARE_FILTER_PRE_IN := sed \
+ -e 's,foo,bar,' \
+ $(NULL)
+
+COMPARE_FILTER_PRE_OUT := sed \
+ -e 's,^usr/lib/firefox-3.1[^/]*/,,' \
+ $(NULL)
+
+COMPARE_FILTER_IN := sed \
+ -e 's,^usr/lib/firefox-3.1[^/]*/searchplugins,usr/lib/firefox-addons/searchplugins,' \
+ -e 's,^usr/lib/firefox-3.1[^/]*/extensions/inspector@mozilla.org/.*,,' \
+ -e 's,^usr/lib/firefox-3.1[^/]*/extensions,usr/lib/xulrunner-addons/extensions,' \
+ -e 's,^usr/lib/firefox-3.1[^/]*/defaults/profile,etc/firefox-3.1/profile,' \
+ -e 's,^usr/lib/firefox-3.1[^/]*/\(old-homepage-default.properties\|README.txt\|removed-files\),,' \
+ -e 's,^usr/lib/firefox-3.1[^/]*/.autoreg,,' \
+ -e 's,^etc/firefox-3.1[^/]*/.autoreg,,' \
+ $(NULL)
+
+COMPARE_FILTER_OUT := sed \
+ -e 's,^DEBIAN/.*,,' \
+ -e 's,^usr/lib/debug/.*,,' \
+ -e 's,^usr/share/doc/.*,,' \
+ -e 's,^usr/share/menu/.*,,' \
+ -e 's,^usr/share/applications/.*,,' \
+ -e 's,^usr/share/bug/firefox-3.1/presubj,,' \
+ -e 's,^etc/firefox-3.1/\(firefoxrc\|pref/firefox.js\),,' \
+ -e 's,^usr/lib/firefox-addons/searchplugins/\(debsearch\|wikipedia\).\(gif\|src\),,' \
+ -e 's,^usr/lib/firefox-3.1[^/]*/\(firefox-3.1-restart-required.update-notifier\|firefox.cfg\|firefox.sh\|ffox-4-beta-profile-migration-dialog\),,' \
+ $(NULL)
+
+include compare.mk.in
diff --git a/src/xulrunner-1.9.1.mk.in b/src/xulrunner-1.9.1.mk.in
new file mode 100644
index 0000000..9552ac3
--- /dev/null
+++ b/src/xulrunner-1.9.1.mk.in
@@ -0,0 +1,62 @@
+# -*- mode: makefile; coding: utf-8 -*-
+
+# Copyright (c) 2008 Fabien Tassin <fta@sofaraway.org>
+# Description: Project XULRunner 1.9.1
+#
+# This program is free software; you can redistribute it and/or
+# modify it under the terms of the GNU General Public License as
+# published by the Free Software Foundation; either version 2, or (at
+# your option) any later version.
+#
+# This program is distributed in the hope that it will be useful, but
+# WITHOUT ANY WARRANTY; without even the implied warranty of
+# MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the GNU
+# General Public License for more details.
+#
+# You should have received a copy of the GNU General Public License along
+# with this program; if not, write to the Free Software Foundation, Inc.,
+# 51 Franklin Street, Fifth Floor, Boston, MA 02110-1301 USA.
+
+MOZCLIENT_TARGET := xulrunner-1.9.1-orig
+MOZCLIENT_APPNAME := xulrunner-1.9.1
+MOZCLIENT_PROJECT := mozilla-central
+MOZCLIENT_FILE := mozilla/config/milestone.txt
+MOZCLIENT_GETVERSION := tail -1 $(MOZCLIENT_FILE) | sed -e 's/pre//; s/\([ab]\)\([0-9]*\)/~\1\2/'
+MOZCLIENT_VCS := hg
+MOZCLIENT_POSTCOCMD := cd mozilla && python client.py checkout
+MOZCLIENT_URL := http://hg.mozilla.org/index.cgi/$(MOZCLIENT_PROJECT)/log
+MOZCLIENT_GETDATE = wget -O - -q --read-timeout=10 --user-agent='' --tries=3 $(MOZCLIENT_URL) 2> /dev/null | \
+ grep cite | head -1 | sed -e 's,.*</cite>,,' | \
+ perl -e '$$m = { "Jan" => 1, "Feb" => 2, "Mar" => 3, "Apr" => 4, "May" => 5, "Jun" => 6, \
+ "Jul" => 7, "Aug" => 8, "Sep" => 9, "Oct" => 10, "Nov" => 11, "Dec" => 12 } ; $$a = <>; \
+ $$a =~ m/^ - \S+,\s+(\d+) (\S+) (\d+) \S+ \S+ - rev (\d+)/ && do { \
+ printf "%d~%04d%02d%02d\n", $$4, $$3, $$$$m{$$2}, $$1 }; '
+#MOZCLIENT_EMBEDDED := 1
+MOZCLIENT_WANTMOZDIR := 1
+
+include mozclient.mk.in
+
+COMPARE_FILTER_PRE_IN = sed \
+ -e 's,foo,foo,' \
+ $(NULL)
+
+COMPARE_FILTER_PRE_OUT = sed \
+ -e 's,^usr/share/idl/.*,,' \
+ -e 's,^usr/include/.*,,' \
+ -e 's,^usr/lib/pkgconfig/.*,,' \
+ -e 's,^usr/lib/xulrunner-devel.*,,' \
+ -e 's,^usr/lib/xulrunner-1.9.1[^/]*/,,' \
+ -e 's,^etc/gre.d/.*,,' \
+ $(NULL)
+
+COMPARE_FILTER_IN = sed \
+ -e 's,usr/lib/xulrunner-[^/]*/extensions,usr/lib/xulrunner-addons/extensions,' \
+ -e 's,usr/lib/xulrunner-[^/]*/plugins,usr/lib/xulrunner-addons/plugins,' \
+ $(NULL)
+
+COMPARE_FILTER_OUT = sed \
+ -e 's,^DEBIAN/.*,,' \
+ -e 's,^usr/share/doc/.*,,' \
+ $(NULL)
+
+include compare.mk.in