summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorFabien Tassin <fta@ubuntu.com>2008-12-22 01:13:36 +0100
committerFabien Tassin <fta@ubuntu.com>2008-12-22 01:13:36 +0100
commit173e65eae2b7fdd1dba2080f65c6265df4bb507b (patch)
tree04256ff76a22eacea5713b17b837306084e01e80
parentd2b212fe547ef90abce02b9c4c88d0b3683beb33 (diff)
* [mozclient] search the main nobin script in the system wide mozclient
path if we are building with a conf-dir and no script was found - update src/mozclient/lib/MozClient/VCS.pm
-rw-r--r--debian/changelog3
-rw-r--r--src/mozclient/lib/MozClient/VCS.pm17
2 files changed, 18 insertions, 2 deletions
diff --git a/debian/changelog b/debian/changelog
index bc73dbc..d310adf 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -3,6 +3,9 @@ mozilla-devscripts (0.12) UNRELEASED; urgency=low
* [ mozclient ]
- fix hg incorrectly requesting branches
- update src/mozclient/lib/MozClient/Mercurial.pm
+ - search the main nobin script in the system wide mozclient
+ path if we are building with a conf-dir and no script was found
+ - update src/mozclient/lib/MozClient/VCS.pm
-- Fabien Tassin <fta@ubuntu.com> Wed, 26 Nov 2008 15:43:32 +0100
diff --git a/src/mozclient/lib/MozClient/VCS.pm b/src/mozclient/lib/MozClient/VCS.pm
index 1471474..29963ec 100644
--- a/src/mozclient/lib/MozClient/VCS.pm
+++ b/src/mozclient/lib/MozClient/VCS.pm
@@ -280,11 +280,24 @@ sub nobin_cleanup {
$self->LOG("MozClient::nobin_cleanup()");
$self->chdir($self->work_dir . "/" . $self->{'MOZCLIENT_MOZDIRNAME'});
- my $cmd = sprintf "sh %s > REMOVED+${nobinonly}.txt 2>&1",
- $self->{'MOZCLIENT_EXCLUDE_SCRIPT'};
if (-e $self->{'MOZCLIENT_EXCLUDE_SCRIPT'}) {
+ my $cmd = sprintf "sh %s > REMOVED+${nobinonly}.txt 2>&1",
+ $self->{'MOZCLIENT_EXCLUDE_SCRIPT'};
$self->run_shell($cmd);
}
+ elsif (defined $INC[1] && $INC[1] =~ m,(.*/mozclient)/,) {
+ my $dir = $1;
+ $self->{'MOZCLIENT_EXCLUDE_SCRIPT'} =~ m,/([^/]*)$,;
+ my $file = $1;
+ if (-e "$dir/$file") {
+ my $cmd = sprintf "sh %s > REMOVED+${nobinonly}.txt 2>&1",
+ "$dir/$file";
+ $self->run_shell($cmd);
+ }
+ else {
+ $self->LOG("*warn* can't find $dir/$file");
+ }
+ }
else {
$self->LOG("*warn* can't find " . $self->{'MOZCLIENT_EXCLUDE_SCRIPT'});
}