summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorFabien Tassin <fta@sofaraway.org>2008-06-19 23:32:15 +0200
committerFabien Tassin <fta@sofaraway.org>2008-06-19 23:32:15 +0200
commit344eb5b30a33eec39030f12ee5597ed8baa7f56e (patch)
tree9d1fcf31ff95e49f5a5137a961f55e3245356c9c
parentae8b1aa513fa2913514bb6030a92a5ac0bf852a4 (diff)
* [mozclient] add project for Fennec using hg
- add src/mozclient/fennec.conf - add src/fennec.mk.in - update src/Makefile - update README
-rw-r--r--README1
-rw-r--r--debian/changelog5
-rw-r--r--src/Makefile1
-rw-r--r--src/fennec.mk.in22
-rw-r--r--src/mozclient/fennec.conf26
5 files changed, 55 insertions, 0 deletions
diff --git a/README b/README
index f1ed9e9..f570c7a 100644
--- a/README
+++ b/README
@@ -16,6 +16,7 @@ The package contains rules for the following projects:
- firefox-3.0
- firefox-3.1
- firefox-4.0
+ - fennec
- lightning-sunbird (from MOZILLA_1_8_BRANCH)
- nspr
- nss
diff --git a/debian/changelog b/debian/changelog
index e77e864..e48c586 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -43,6 +43,11 @@ mozilla-devscripts (0.09) UNRELEASED; urgency=low
- add src/mozclient/flock-remove.binonly.sh
- update src/Makefile
- update README
+ + add project for Fennec using hg
+ - add src/mozclient/fennec.conf
+ - add src/fennec.mk.in
+ - update src/Makefile
+ - update README
+ use an absolute path for remove.binonly.sh as with --conf-dir it could
be called from anywhere. Move remove.binonly.sh into mozclient
- move src/remove.binonly.sh => src/mozclient/remove.binonly.sh
diff --git a/src/Makefile b/src/Makefile
index 61a2b88..324bab3 100644
--- a/src/Makefile
+++ b/src/Makefile
@@ -26,6 +26,7 @@ subst_files = \
firefox-3.0-full.mk \
firefox-3.1.mk \
firefox-4.0.mk \
+ fennec.mk \
lightning-sunbird.mk \
nspr.mk \
nss.mk \
diff --git a/src/fennec.mk.in b/src/fennec.mk.in
new file mode 100644
index 0000000..8992155
--- /dev/null
+++ b/src/fennec.mk.in
@@ -0,0 +1,22 @@
+# -*- mode: makefile; coding: utf-8 -*-
+
+# Copyright (c) 2008 Fabien Tassin <fta@sofaraway.org>
+# Description: Project Fennec
+#
+# This program is free software; you can redistribute it and/or
+# modify it under the terms of the GNU General Public License as
+# published by the Free Software Foundation; either version 2, or (at
+# your option) any later version.
+#
+# This program is distributed in the hope that it will be useful, but
+# WITHOUT ANY WARRANTY; without even the implied warranty of
+# MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the GNU
+# General Public License for more details.
+#
+# You should have received a copy of the GNU General Public License along
+# with this program; if not, write to the Free Software Foundation, Inc.,
+# 51 Franklin Street, Fifth Floor, Boston, MA 02110-1301 USA.
+
+MOZCLIENT_PROJECTNAME := fennec
+
+include mozclient.mk.in
diff --git a/src/mozclient/fennec.conf b/src/mozclient/fennec.conf
new file mode 100644
index 0000000..4ee42ab
--- /dev/null
+++ b/src/mozclient/fennec.conf
@@ -0,0 +1,26 @@
+# Copyright (c) 2008 Fabien Tassin <fta@sofaraway.org>
+# Description: Project Fennec
+#
+# This program is free software; you can redistribute it and/or
+# modify it under the terms of the GNU General Public License as
+# published by the Free Software Foundation; either version 2, or (at
+# your option) any later version.
+#
+# This program is distributed in the hope that it will be useful, but
+# WITHOUT ANY WARRANTY; without even the implied warranty of
+# MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the GNU
+# General Public License for more details.
+#
+# You should have received a copy of the GNU General Public License along
+# with this program; if not, write to the Free Software Foundation, Inc.,
+# 51 Franklin Street, Fifth Floor, Boston, MA 02110-1301 USA.
+
+MOZCLIENT_APPNAME = fennec
+MOZCLIENT_PROJECT = mobile-browser
+MOZCLIENT_FILE = mozilla/confvars.sh
+MOZCLIENT_GETVERSION = grep ^MOZ_APP_VERSION mozilla/confvars.sh | cut -d= -f2 | sed -e 's/pre//; s/\([ab]\)\([0-9]*\)/~\1\2/'
+MOZCLIENT_VCS = hg
+MOZCLIENT_VCS_LOC = http://hg.mozilla.org/
+MOZCLIENT_GETDATE = wget -O - -q --read-timeout=10 --user-agent='' --tries=3 http://hg.mozilla.org/index.cgi/mobile-browser/log 2> /dev/null | grep cite | head -1 | sed -e 's,.*</cite>,,' | perl -e '$m = { "Jan" => 1, "Feb" => 2, "Mar" => 3, "Apr" => 4, "May" => 5, "Jun" => 6, "Jul" => 7, "Aug" => 8, "Sep" => 9, "Oct" => 10, "Nov" => 11, "Dec" => 12 } ; $a = <>; $a =~ m/^ - \S+,\s+(\d+) (\S+) (\d+) \S+ \S+ - rev (\d+)/ && do { printf "%04d%02d%02dr%d\n", $3, $$m{$2}, $1, $4 }; '
+MOZCLIENT_EMBEDDED = 0
+MOZCLIENT_WANTMOZDIR = 0