summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBenjamin Drung <bdrung@ubuntu.com>2009-10-07 16:26:23 +0200
committerBenjamin Drung <bdrung@ubuntu.com>2009-10-07 16:26:23 +0200
commit44b36b089993c52f73643296e1554f87dfcaa55c (patch)
tree98f7e2039b6a90dc741fdfb2b6fe46bbc2a8d38f
parentd366930b3bbd883bbb00c56f30fbcdd27c766844 (diff)
- set default MOZ_XPI_DISTRO in xpi-config.mk on installation
- add src/xpi-config.mk.in - rename src/xpi.mk.in back to src/xpi.mk and update it - update src/Makefile
-rw-r--r--debian/changelog13
-rw-r--r--src/Makefile3
-rw-r--r--src/xpi-config.mk.in20
-rw-r--r--src/xpi.mk (renamed from src/xpi.mk.in)7
4 files changed, 35 insertions, 8 deletions
diff --git a/debian/changelog b/debian/changelog
index be63f6b..9373e95 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -11,9 +11,8 @@ mozilla-devscripts (0.17) UNRELEASED; urgency=low
- support different types of install.rdf files (LP: #442897)
- update src/xpi.mk
- move data for the automagic detection of target application packages
- into separate xpi-data-*.mk files and set default MOZ_XPI_DISTRO when
- installing mozilla-devscripts
- - rename src/xpi.mk to src/xpi.mk.in and update it
+ into separate xpi-data-*.mk files
+ - update src/xpi.mk
- add src/xpi-data-all.mk
- add src/xpi-data-common.mk
- add src/xpi-data-Debian.mk
@@ -21,9 +20,13 @@ mozilla-devscripts (0.17) UNRELEASED; urgency=low
- update debian/control
- update src/Makefile
- rename MOZ_EXT_NAME to MOZ_XPI_EXT_NAME
- - update src/xpi.mk.in
+ - update src/xpi.mk
+ - set default MOZ_XPI_DISTRO in xpi-config.mk on installation
+ - add src/xpi-config.mk.in
+ - update src/xpi.mk
+ - update src/Makefile
- -- Benjamin Drung <bdrung@ubuntu.com> Tue, 06 Oct 2009 19:17:17 +0200
+ -- Benjamin Drung <bdrung@ubuntu.com> Wed, 07 Oct 2009 16:19:10 +0200
mozilla-devscripts (0.16) unstable; urgency=low
diff --git a/src/Makefile b/src/Makefile
index bb4a97b..0a78d46 100644
--- a/src/Makefile
+++ b/src/Makefile
@@ -43,12 +43,13 @@ subst_files = \
mozclient.mk \
compare.mk \
minefield-packager.mk \
- xpi.mk \
+ xpi-config.mk \
xulapp.mk \
$(NULL)
extra_files = \
lp-locale-export.mk \
+ xpi.mk \
xpi-data-all.mk \
xpi-data-common.mk \
xpi-data-Debian.mk \
diff --git a/src/xpi-config.mk.in b/src/xpi-config.mk.in
new file mode 100644
index 0000000..864f081
--- /dev/null
+++ b/src/xpi-config.mk.in
@@ -0,0 +1,20 @@
+# -*- mode: makefile; coding: utf-8 -*-
+
+# Copyright (c) 2009 Canonical Ltd.
+# Author(s): Benjamin Drung <bdrung@ubuntu.com>
+#
+# This program is free software; you can redistribute it and/or
+# modify it under the terms of the GNU General Public License as
+# published by the Free Software Foundation; either version 2, or (at
+# your option) any later version.
+#
+# This program is distributed in the hope that it will be useful, but
+# WITHOUT ANY WARRANTY; without even the implied warranty of
+# MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the GNU
+# General Public License for more details.
+#
+# You should have received a copy of the GNU General Public License along
+# with this program; if not, write to the Free Software Foundation, Inc.,
+# 51 Franklin Street, Fifth Floor, Boston, MA 02110-1301 USA.
+
+MOZ_XPI_DISTRO ?= @DISTRO@
diff --git a/src/xpi.mk.in b/src/xpi.mk
index 858d18b..6399673 100644
--- a/src/xpi.mk.in
+++ b/src/xpi.mk
@@ -82,10 +82,13 @@
# to MOZ_XPI_EXT_NAME
#
-MOZ_XPI_DISTRO ?= @DISTRO@
+_xpi_makefile_path ?= /usr/share/mozilla-devscripts
+
+-include $(_xpi_makefile_path)/xpi-config.mk
+
+MOZ_XPI_DISTRO ?= all
# xpi-data-*.mk must define packages_*, *_sol, and *_eol
-_xpi_makefile_path ?= /usr/share/mozilla-devscripts
include $(_xpi_makefile_path)/xpi-data-$(MOZ_XPI_DISTRO).mk
# data for XPI_RECOMMENDS/CHECK_VERSION magic - targetApplication min-/maxVersions