summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBenjamin Drung <bdrung@debian.org>2012-12-07 01:59:40 +0100
committerBenjamin Drung <bdrung@debian.org>2012-12-07 01:59:40 +0100
commit4729385569c3c3169b6cc9abbb82bf96b4630ba1 (patch)
treec8fec89ae9809facc2c678e8cf6655128ae0d49b
parenta757d416250b382058407db0d611c14337c18451 (diff)
Improve error message (tell user how to fix it).
-rwxr-xr-xdh_xul-ext6
1 files changed, 4 insertions, 2 deletions
diff --git a/dh_xul-ext b/dh_xul-ext
index 1486c14..418feb8 100755
--- a/dh_xul-ext
+++ b/dh_xul-ext
@@ -189,9 +189,11 @@ def _get_id_max_min_triple(script_name, package, install_rdf):
# Sanity check version range
if compare_versions(min_version, max_version) > 0:
msg = ("%s: %s contains an invalid version range for %s:\n"
- "%s: minVersion <= maxVersion is required, but %s > %s.") % \
+ "%s: minVersion <= maxVersion is required, but %s > %s.\n"
+ "%s: Please either fix the versions or remove the entry "
+ "from install.xpi.") % \
(script_name, package, appid, script_name, min_version,
- max_version)
+ max_version, script_name)
print >> sys.stderr, msg
failures += 1
if failures > 0: