summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSasa Bodiroza <jazzva@gmail.com>2008-07-08 23:06:44 +0200
committerSasa Bodiroza <jazzva@gmail.com>2008-07-08 23:06:44 +0200
commit553f700b449a06d7f0a2f5c9d55300f7af1088fc (patch)
treeebfc9f26dc46414619ff66d726e6c0fa366eef0e
parenta2bb8499aa1cd9b00c25f2510e1f1228659def97 (diff)
* In src/xpi.mk:
- Revert clean rule, removed in rev 158. - Change default build cmd to not remove xpi files, it is done in clean rule. - Use CURDIR instead of pwd in default build cmd. * Document in debian/changelog.
-rw-r--r--debian/changelog5
-rw-r--r--src/xpi.mk7
2 files changed, 6 insertions, 6 deletions
diff --git a/debian/changelog b/debian/changelog
index c14e874..71293ff 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -3,10 +3,7 @@ mozilla-devscripts (0.10) UNRELEASED; urgency=low
* Open tree for 0.10 development.
* Add src/med-xpi-{pack,unpack} scripts to manage packing and unpacking of
XPI files.
- * In src/xpi.mk:
- - Add default build command.
- - Remove part of clean target, which checks if build command is defined,
- because now we always have a build command (default, or provided by dev).
+ * Add default build command in src/xpi.mk.
* In README:
- Document src/med-xpi-{pack,unpack} scripts.
- Document default build command in xpi.mk part.
diff --git a/src/xpi.mk b/src/xpi.mk
index 5fb3583..d62dcd2 100644
--- a/src/xpi.mk
+++ b/src/xpi.mk
@@ -51,7 +51,7 @@
MOZ_XPI_MOZILLA_DIRS ?= firefox-addons firefox
-MOZ_XPI_BUILD_COMMAND ?= rm -f `pwd`/*.xpi ; med-xpi-pack `pwd` $(MOZ_EXTENSION_PKG).xpi;
+MOZ_XPI_BUILD_COMMAND ?= med-xpi-pack $(CURDIR) $(MOZ_EXTENSION_PKG).xpi;
TEMPDIR := $(shell rm -rf temp-xpi-*; mktemp -d temp-xpi-XXXXXXXX)
@@ -76,8 +76,11 @@ endif
install/$(MOZ_EXTENSION_PKG):: xpi-install
-# clean build
+# clean build and remove all .xpi in top-level if a MOZ_XPI_BUILD_COMMAND is defined
clean:: xpi-clean
+ifneq (,$(MOZ_XPI_BUILD_COMMAND))
+ rm -f *.xpi
+endif
# ### general helper targets
stamp-unzip-%: